Data keep disappearing from the App

My App/Pages Support link:

I can add data in the app, and all the calculations and components appear as they should. However, when I return to the account page and re-open the same App, the data just added have disappeared. The same also happen if I open the App on the phone.

What is happening??? I am using a public access (no email required), and the APP is in the “My Apps” folder.

Help please!

Do you store all your calculations in user-specific columns, and you have not logged in?

I have been experiencing similar bugs today. They include data disappearing or not showing.

1 Like

I do not have any user specific columns

So is this a bug central from Glide? If they resolve it, will the data appear all together?

I have a similar issue, recently, In my case Im using googlesheet as database, I noticed it is due to calculation going to and from between glide and googlesheet. Calculation is an arrayformula to get the age.

This is normal. You could avoid this delay by doing the calculation in Glide using a math column.

thanks but this Im still not able to find a sample or figure it out how to get the age calculation using glide tables thus I need to stick for now in googlesheet calculation.

Hopefully this weekend If I have time how to get the age by comparing to dates, and to show it in normal sentence (maybe by template) . I did see the time relevance but I dont see documention how format works.

I’m not sure what you’re trying to show in that video.

Anyway, to calculate the “age” of something in years, it’s a very simple calculation:


1 Like

Thanks to all the contributors, but the problem of “data disappearing” remains, it is not linked to using GSheet, Glide table or a particular formula…

Do we have any update from Glide?
@david do you have any notification of issues on this topic?


1 Like

oh… intend to show that the data is disappearing from time to time.
thanks much for the tip. thought it will just show the years rounded, what I Actually need is the with years, months and days in one senctence. =)

Okay, that’s possible but requires a few extra columns. But we’re getting off topic here. If you start a new topic and ask that question, I’ll show you how.

1 Like

yeah, haha im hijacking someones topic here .
although we share similar issue of dispappearing data from glide table.

Please submit a support ticket with all the information required.

I had that issue earlier this week. I submitted a ticket and one of the possible suggestions that was offered was (because I am using Google Sheets) to make a copy of the file and set it as the new data source for the app. That worked for me. Somehow my Google sheet had become disconnected and was no longer receiving data. The new sheet worked seamlessly.

Similar issue for me, when I try to add a new record the data appear and then disappear. I’m using Glide Table. In addition I can’t see anymore refresh icon in data editor.

Update: I can say that I can’t add record in tables with row id. Where I haven’t row id I can add records.


1 Like

Glide tables don’t need the refresh (sync) button because there is nothing to sync, unlike a google sheet, which needs to sync the data between the Google sheet and Glide’s copy of that sheet data. If you are working with a Glide Table, then you are already working with the only copy of that data. I would try refreshing the browser, and possibly clearing the browser cache.

Update: I can say that I can’t add record in tables with row id. Where I haven’t row id I can add records.

but all users who use my app have the same problem. I don’t think that the browser cache is the problem.

Before refresh (you can see the record n. 137)

Then refresh (record n.137 disappear)