Data from Airtable only displays in incognito

Hey there! I have an issue. I’m integrating AT as my datasource but it only displays in my app when I open the published app in incognito. Please see the screenrecording below. I have reconnected Airtable and it still doesn’t fix the problem. The data appears available and loaded in the Data tab from within the editor, but it just doesn’t display in the app within the editor.

That’s weird. Do you have any visibility conditions/filters tied to those lists?

I do not. It’s frustrating. I wish I could just create a support ticket for what seems like a bug but Glide just points me to this forum. Hopefully someone else has had and resolved this issue.

Have you tried it with another browser?

Yes, but unfortunately I haven’t been able to figure out the problem. Glide works as expected in Safari, but in Arc (my normal browser) it is not working (hence this thread). But this is a new issue, as of the last few days. Previously it was working just fine in Arc. And yes, I already did an all-time history/cookies/cache clearing and it didn’t change anything.

Can I get support from Glide somehow?

Have you tried disabling extensions?

No, nor do I plan to. I need my extensions, and the bigger issue is that it was previously working WITH my extensions. ThinhDinh, do you know of a way to contact Glide Support?

Extensions have caused issues for people in the past because they can interfere with underlying cookies and/or code. The fact that everything worked before doesn’t prove that it’s an issue with Glide or the extensions.

My career is based on debugging and fixing code every day, and 90% of the battle is knowing how to reproduce an issue. Fixing issues is easy when you know what you are fixing. I recall an issue we had at my company in the past where we had a particular user that disabled javascript and things didn’t work when they used our website. We didn’t know they had javascript disabled because who would and who would ever expect that to be an issue most of the time. It took our support team a long time and several screen sharing calls to figure out that the user had javascript disabled and the only fix was for the user to turn it back on. We didn’t know how to reproduce it until we figured out that tidbit. As a developer, if it works on my end, I won’t know what to fix.

Before jumping the gun, it would at least be helpful if you can please
try to eliminate some rogue extension as the source of the problem by disabling them at least temporarily. If that doesn’t work, then I would clear cache and cookies in the browser. If there is still an issue, then open a support ticket. My guess is that if you submit a ticket now, they may not be able to reproduce the issue or know how to reproduce it to fix anything…if it’s even a Glide issue.

Glide support is available on Pro plans and above.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.