Can't disable search bar and just index some data

I can’t disable the search bar in this view. Even if I search for a name don’t show any results. At least if I have to leave it why is not indexing any results? What I have to do to be able to deactivate the search bar please

Video loom

Do you see the label “Search is enabled because there are searchable components on the page.”? This means that search is enabled on some inline lists on your page.