Can Glide please remove this message post use of embedded payment forms?

@Mark @_eric

I’m guessing that the error message in the screenshot below is a Glide message, please confirm?

It appears after a payment has been processed using an embedded payment form.

Can this please be removed since the transaction is secure and successfully processed. This message gives the incorrect indication to the user.

ps: I hope Glide is not trying to limit the use of payment forms.

This message is not generate by Glide.

My guess is it’s a result of the form being embedded as an iframe.

thanks for confirming that! my guess was when it seems to appear above the webview component.

I’ve logged a call with the 3rd party provider to investigate.

doubt is that, as they officially support it by providing the code to embedded the form as an iframe.

I’ve had a response from the third-party and the error message is not coming from their end.

I was asked to test the payment form using the URL separately on the browser and that tested successfully, so this points to Glide.

Can you please check your end?

Which browser and OS is the app running on top of? I’m thinking it may be the browser itself issuing the warning. Most likely something to do with SSL to non-SSL content through the iframe, or cross site embedding. I’m guessing the browser is throwing caution because it’s seeing something as potentially suspicious, even though it’s legitimate. Probably to combat situations where a scammer could embed bad code in a site to trick user’s into giving up personal or financial information. I’m not calling you a scammer :wink: , but browsers have a lot of this stuff built in to help protect users from suspicious websites.

1 Like

Running the app on iOS…Not sure if you’ve read the thread, but the issue is not on the browser. The issue is on the glide app itself.

I can’t see the browser positioning the error message perfectly between an image component and a webview component.

I have tested it on a browser and it works fine. I am getting the error in the glide app only.

Glide apps (and all PWA’s for that matter) are still run with the browser as the underlying engine. They are still HTML, JavaScript, CSS based webpages with heavy caching and a browser wrapper without the extra browser UI.

I’m guessing the message is inside the webview component, thus the positioning at the top of the webview.

All I’m saying is that if neither side is claiming the error, then it’s possible that Safari is triggering it for some reason.

If you have a sample app, then maybe some of us can take a look and see if anything stands out when inspecting the page source.

1 Like

Jeff,

I’m scratching my head trying to figure out.

Here is the link to the app, I’ve created a ‘Test’ tab with a single ‘Pay Now’ button that links to screen (This item), it then loads the webview in addition to a simple image component at the top.

edit: I’ve also added a second button that opens an external link to the form URL

Processing the payment using the direct URL in Safari does not throw the error. It only throws it when embedded in the Glide app.

https://zohosecurepay.com/checkout/3f66l7u-ygxufpsvhutfu/SZN-Digital-Authentication

I would say this is a pretty good indication that the message is coming either from the browser or ZoHo.

This is a different message from a test card through the app.

Same message when visiting the direct purchase link outside of the app.

I have to wonder if Zoho doesn’t explicitly have an error like that in their code, but they are catching a general web exception in their code and passing it through to their error notification.

2 Likes

Yeah, it does appear that way, Thanks for looking up into this Jeff.

I have reached out to Zoho again and will discuss your findings.

2 Likes

Mark, I just had a remote session with the Zoho Checkout remote support team, we reviewed all the settings of the checkout form including the re-direct settings which points to a page that displays a simple “Thank you for your payment” message after a successful charge.

The support team advises that the error in the screenshot below is due to permissions to load the “Thank you” page. Perhaps the message below helps you/your team to investigate?