Camera not working

My app is having an issue taking photos. When I click on the upload field and then click “Take Photo”, the photo screen is completely black and I it doesn’t allow me to take a photo. I can however take it with my phone and then go to photo library to upload it. Is there a setting that needs to be changed to give the app access to my camera?


1 Like

Seems to work for me. Have you tried restarting your device or trying a different device?

Hi, I have the same problem too.
I can’t upload directly from my phone camera. But when i try upload from my phone gallery the uploading process is success.

Having the same issue. Any solution for the above problem mentioned?

1 Like

This is an iOS bug that only Apple can fix. We don’t have any news about it.

This is pretty key functionality for my app. What can be done to fix it? Obviously other apps allow direct access to the camera. What is going on behind the scenes that keeps glide apps from being able to directly use the iOS camera? Asking as a paid subscriber really wanting to continue using glide. Which I love.

What kind of problems are there? Are you on the latest version of IOS?

I don’t know if this is related, but the image picker will not work for me this morning. I can’t upload images from my photo library or from the camera directly. iPhone 7 iOS 13.4. @Mark can you look? Tested yesterday and it worked just fine. Absolutely need this functionality this morning (and this week) as I’m documenting evidence of returned equipment.


It works for me. Could you please share a video and the app? Are your images very large?

Images are not large…I even choose the “small” option in iOS.

Video still uploading/processing:

Could you share that app and whitelist me for it, please?

Will whitelist momentarily. Thanks for taking a look!

We found the problem. If you want a workaround before we’ve fixed it, make your email whitelist sheet explicit, i.e. list every email address in there (particularly yours, if you’re the one uploading).

Awesome! Thanks. Makes sense…it was working for me in the builder, but not the published app. Perfect! You are seriously the best.