Bug(?) Duplicating a Glide App - not all Glide tables being imported into new App

I duplicated a Glide App within the same Team using 'Copy the Sheet". I renamed the google sheet and all was good except…a Glide table did not get duplicated.

I deleted the new project and duplicated again (same methodology)
The Glide table was correctly duplicated this time. BUT - I just discovered a different Glide table was not duplicated (in fact a more important table).

Are the Glide tables duplicated or is it just a pointer? If I delete the table and then ‘add/link’ it back in, will the App know and not break all the screens dependent on this table (which are quite a few actually).

Or should I just delete the App and re-duplicate it?


The issue is the Glide table is empty in the 'Duplicated" project but is correct in the previous version which I duplicated from. I thought this was just a linked table so they should be exactly the same but now not so sure.

The correct method I am asking about is if I unlink the now empty table and link it back in will I have any issues within Glide referencing the data? Since this table is being used in a previous version of the App and contains the correct data, I am hoping it is this simple (still not sure why a linked table is different but I may not understand how Glide works/caches/references Glide tables across Apps in a Team).

FYI…I duplicated the Project as I am now showing the App to prospects and I wanted a clean build so I can walk through a DEMO and have it work identically. My goal was to replicate this version for each demo so I had a clean database rather than deleting rows in all the tables which are updated while demoing the app (which are in Sheets and Glide tables)

Also, I am still updating the ‘DEV’ app (I am adding a new feature and I manually tracking the database changes and screen updates).

TIA as always

I’ve seen this behaviour, and I’ve reported it to Glide.

The workaround that I’ve been using is to add a row to the empty table and then wait a few seconds. This seems to kick things into gear and the original rows should show up. You can then delete the row that was added, and the universe will be all good again :slightly_smiling_face:

1 Like

Shut the H E double toothpicks up!!

Worked like a charm…thanks Darren

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.