Array Columns no longer generating relations?

My app’s URL:

Suddenly this evening, the multiple relations I had set up off of an array column disappeared:

  1. :white_check_mark:Sheet is set up correctly

  2. :white_check_mark:Array Column is visible

  3. :white_check_mark: Relation Sheet values named the same:
    Screen Shot 2020-02-25 at 10.09.21 PM

  4. :interrobang: Relation of array column to the second sheet is now empty?!

Should look like this (grabbed from a recent vid I made):

Hi @Robert_Petitto!

I just had the same problem some minutes ago. I had just finished setting up a relation between two Array columns in different tabs and a Lookup column to retrieve data through that relation. It worked like a charm for some time until my app stopped working and all the columns containing data were empty.

In case this can help, a platform update took place more or less at the same time everything stopped working. As a result of the update, among other things, the “upgrade to pro” and “share app” buttons had been relocated to a different place.

After trying to solve the problem unsuccessfully, I decided to build a simple app from scratch, with nothing more than an array relation between two basic tables, but it did not work either.

I hope this is just a bug and everything goes back to normal soon. Setting up array relations is a very useful resource that makes GlideApps very powerful!

1 Like

I’m on it.

1 Like

Whew…okay. So nothing I did (probably). Any ideas, @Mark?

Mark be like


Yeah…same thing happening in 3 other columns as well in my app. Any relation column that’s referencing an array column is coming up empty.

This captures reality more accurately:

In any case, a fix should land in 30 minutes or so. Apologies for the distruption.


Ha…no worries. Going to bed anyway…when I wake up, I’ll realize it had only been a dream.

Great, thanks! :+1:

Should be fixed now. Could you please confirm, @Alfonso_Aguilar?

Now it works! Many thanks @Mark for fixing it so quickly.

1 Like


I’m suffering the same bug right now. Any column that’s an array of several numbered columns is no longer recognized in a relation. Not sure when this began but pretty much every list, relation, or inline list component that relies on a relation column made up of a relationship with an array column is currently blank in my app. I’m assuming it’s the same bug you guys were discussing yesterday and likely my app was affected then too… but whatever fix you did @Mark, it didn’t fix it in mine.

@John_Cabrera Could you point me to the app and tell me exactly what to do to reproduce the bug?

Ugh, I was afraid you’d ask that. My app is whitelisted and I’m trying to keep it under wraps as I build.

Currently crippling my app since most of my relation columns are with array columns. Can I post some images as @Robert_Petitto did?

You can pm him the link. They can bypass the whitelist.

So here’s what I have in one of my sheets. The JID column of this sheet is relating to an array of two columns in the Lor sheet each called JID_1 and JID_2 ( together called JID_ )

Annotation 2020-02-26 121545

And if I change this to only relate to one of the two columns (in this case JID_1), the data returns… of course, only for that one column.

Annotation 2020-02-26 121742

Should be fixed in about 30 minutes. This affected relations going between array columns and individual number columns.

1 Like

All seems to be in order again. Thanks, @Mark.

Hi @Mark ,

I think I’m facing the same issue. I have a situation where I’m fetching all the students who have enrolled for a teacher. I’ve created a relation in the tutor table where tutor_table.tutor_name = student_table.tutorname. The results are showing up in the data editor but the list at the front end editor is not recognising values and are showing up as blank.

I’ve dropped a PM as well with the app link. Would really appreciate it if you could help.