An EASIER and LEANER Trebuchet Method for Multiselect

No more ifComma columns, template columns or series of Set Column actions to add and remove items from a multiselect list.

Thanks to @Jeff_Hager for the inspiration!


Just watched your video, very good!

You + @Jeff_Hager have made great progress with this ‘conundrum’

I need to have a play around with this but it’s certainly is leaner and appears easier to execute.

Hoping in the future we will have something like this built natively in glide…until then this certainly hits the spot.


I know! A basic column > Array column would be awesome with actions to add/remove from array.


Very clever

Very impressive.

To add more context, this is the same method I’ve used for multi-select and to be able to clear selections on multiple rows at once.


Thanks @Robert_Petitto ! Great as usual ! Did not onboard Trebuchet method previously, but now time to go for me !!!

1 Like

Thanks for giving us proof of concept, @Jeff_Hager!


Hello, Robert!
If several users will try to use this simultaneously, then they will be overwrite each other temp ids in a item sheet
How to implement this method without any write operation in item sheet, just in user sheet, users row?

As long as you use a user specific column to hold the ID, then it won’t interfere with other users.


Make sure the temp ID is a user specific column or in the user sheet…then it will be user specific and won’t overwrite someone else’s data.


Thanks you’re guys, very much!
About user specific - is looks well, thanks!
But another reason, it to reduce value of writing operations to google table. Off course wee can copy it to glide table but, may be this is not so good idea?

User specific columns are only stored in glide. It doesn’t matter if you add them to a glide table or a google sheet. It will always store the value inside of glide, so you shouldn’t have to worry about any write operations to google sheet when you are only changing the value in a user specific column.

1 Like

Thank you Jeff! It is very useful comment for me!

1 Like

The last section where you display an inline list with the value of rel-itemIDs, I noticed that I am unable to get that list. I can only see the rel- that is under my Users profile.

Any idea why? I have followed the video a few times with same result.

Did you make the relation a multiple relation?

Yes I did. And only through this exercise, I realised I can only access relations that are from the Users table.

I have also tried on my second app, it is the same result. I can only access/display relations from Users table.
Are you using advanced features which are in testing?
Anyone else having same issue as I have?

No…no advanced features.


Can you post a couple of screen shots or a short video?

1 Like