Added columns in "Data" keep disappearing

I’ve been trying to add a column using Glide’s “Data” editor, intended for images (since images in Google Sheets don’t seem able to transfer over). Every time I add a column of any kind (I’ve tried image and text columns), it disappears after 5 seconds.

Am I doing something wrong? Is this a bug? I’m new to Glide, so it’s possible I’m missing something.

Can you verify if the column was added to the google sheet or not? I’m assuming you aren’t creating user specific columns. You can always try refreshing the browser.

Correct, that it’s not user-specific. Nothing’s been added to the sheet, regardless of whether I have Google Sheets open when I try or not, and I’ve tried refreshing Sheets, Glide, closing the browser entirely, and from my tablet’s browser as well. 5 seconds after I made a new column, it disappears. I assume this 5-second delay is updating its check on the sheet’s data?
By the way, in case it’s a question, I’m nowhere near any of the data/row/etc limits.

Hmm, just one more thing to check…do you have a yellow triangle over your sheet reload button in the glide builder? Does everything else datawise sync between glide and the sheet? Otherwise, I have no idea what could be happening.

Sorry for the delay replying. I have seen the yellow triangle before, so I know what it is you mean, but no, not while trying to add a column through Glide.

One more thing to try is to duplicate your app with and without a new sheet to see what it does. Otherwise I’m out of ideas. @Mark

Yeah, I was thinking of trying it from scratch too, with my sheet already completed, since I was trying Glide for the first time, and had to make a lot of adjustments to the sheet.
The only other thing I can think of is perhaps needing some kind of permissions within Google Sheets, but I would think Glide has already taken care of that by login, seeing as how checkboxes were being added into my sheet when I experimented with checklist formatting.

I’ll try redoing the app tomorrow, if nobody’s found a solution by then.

1 Like

Could you share your app, please, and make a video of what you’re seeing?
Here’s the link, though I’m not sure how much it helps. I wanted to add an image column which will be used to mark games as “new”, or unmarked if played before.
And sorry, camera phone video of my tablet. Should suffice though. I click “Add Column” and confirm, and the column disappears.

Update: I just remade it quickly with a brand-new sheet (copy/pasted the data into it) and a brand-new app. It did the same thing.
Then, as I was starting to type this post, I decided, using the same new sheet, to delete everything, and manually type some random values into the same columns. I refreshed the app page, and somehow, I’m able to add an image column now with the new app. So now, two things:

  1. Does anyone have any idea what could be in my sheet to cause this problem? (It’s 9x67 RowsxColumns, with no formulas)

  2. What dimensions do I need for an image in a “List”-style app? The ones I’m using are small enough to fit in the box (30x10px and 49x8px), but are instead blown out of proportion, and don’t fit in the box.

  1. I can’t think of any reason why something in the sheet would be causing an issue.
  2. If an image needs to fit in a square or round placeholder, the square dimensions usually work best.

Thanks. I got everything working in a new sheet and app, with some long workarounds for other issues with nonexistent Glide tools.

1 Like