"Add row" Zapier not bringing in user profile data

My app’s URL: https://go.glideapps.com/app/k9nW8HCBywCLuDryKgga

I’ve got a button called “Invite to Spar 2” which appears on the each of the detail pages on my app. When a user clicks that button, I want a new row to populate on a tab called “Invitations” on my Google Sheet. The new row should consist of 2 values, 1 in column A and 1 in column B. I want the value in column A to be the current user’s name and the value of column B to be the name tied to the details page where the user clicked the button.

I’ve currently got a Zapier set up that performs the action in column B perfectly, however the value in column A is always blank. I’ve tried changing the Zapier inputs for column A to different user-associated and detail-page-associated values. The user-associated values are always blank. The detail-page-associated values always flow through.

Can anyone help?


Use a button with ‘show form’ action.
Pass the current user’s email as the value for column 1.
Use the name from the detail screen as the value for column 2.

I don’t want the user to have to input any data–I want them to be able to click the button and exactly the functionality that I initially described occurs: a column on a google sheet is populated with certain values. I don’t believe the ‘show form’ action will work here for that reason.

Can you try making a template of the user value as a column in the source sheet of the page you’re viewing, then pass that to Zapier instead?

Hi Thinh–I will still need a way to associate the current user in order to correctly pass that value. Unless I’m missing something, the only way for me to pass a value associate with the current user, is to use the functionality built into GlideApps to select a user-associated value. (I.e. Values with this icon: Screen Shot 2020-10-05 at 10.29.28 AM ) To me, this really seems like a bug.

Here’s a screenshot to show what the google sheet looks like after triggering the Zap/clicking the button a few times on different pages.
Screen Shot 2020-10-05 at 10.31.26 AM

The template column allows you to select a user-associated value. Can you try and let me know?

Ahh, I didn’t know what a ‘template column’ was but I just implemented it for the first time and it worked! Thank you!

1 Like