Action to add form


how can I create a custom action for a button to go directly to the add-form (“+”) of a specific tab?
Of course, I can go to that tab, but then I tried “show Form screen” and “show New screen” but without result.


action " Show Form Screen "

thanks, but this seems to be another form than the “normal” add-form when tapping on “+”

You can just copy all components from your configured add screen to that form (special values and on-submit action won’t be copied over).

OK and I think I can do this with your help.
But there’s still the question why Glide uses 2 different forms, one “add form” (with “+”) and another one when using actions…

The “+” is restricted for list views, to specifically add rows to the Sheet you’re using on that screen. When you switch to a details view that option can not be enabled anymore.

Are these “rules” documented anywhere in written form? If not, why not?

Many if not most of the learning modules are pre 2.0 interface. It’s hard to pick up on and memorize all of the “rules” contained in video tutorials. It is much more helpful and efficient to search and browse written documentation that clearly states what you can and cannot do or what you should or should not do.

How about creating a new Category in this forum dedicated to written documentation with separate topics for “forms”, “screens”, “actions”, “user profile”, “components”, etc.? Allow only certified experts to post/edit content (do not permit frivolous responses or chatting) and allow read only access to everyone.

I believe Glide is in the process of updating all documentations to match the 2.0 version. Your idea is nice though, at the moment we’re willing to answer things for users here in the forum, and it would be great to have one centralized place to store those as a wiki to refer to.

I noticed that adding data with the action “show form screen” isn’t synchronized with the underlying Google Sheet.
I can only see the new data in the Glide table (visible with the small table icon above the editor).

Is this a bug? Or did I do something wrong?

Same question, but now I’m wondering if we have a larger problem here. This is the third report this morning.

Also, are you sure the data is not at the very bottom of the sheet?

Good suggestion and indeed…
I had 3 rows with data in the (test-)sheet and added (within GS) some lookup formulas in new columns. Then I copied those formulas to row 100 (to be used with every new data-line).
Now, my 4th added data is on line 101. Instead of on line 4

So, it’s not a bug, but Glide thinks those formulas are data-lines and add the 4th input below.
Not totally unlogic, but this brings me to some problems, as vlookup and importrange-formulas are not possible within Glide.
I’ll try to delete those formulas in my sheet and adding an new sheet in my GS with vlookup-linking to my original sheet and add those formulas there.

1 Like

Can you explain your formulas in more detail? Is it something that could be done in glide with relations and lookups? There are better ways to handle formulas in google sheets, such as arrayformulas, but if you can do the same thing with glide columns, then you are much better off.

1 Like

The sheet includes very complex calculations. Team has been working on the sheet for very long & that’s the preferred medium. Everything was working fine till day before midnight. We’ve been facing this issue since yesterday morning.

Attaching screenshots FYR:

  1. A/c status - spare space/edits etc

Pls. help

Its not.
Sharing screenshots FYR: Glide Issue - Edits in app not getting reflected in GSpreadsheet - Google Drive

  1. App front end where we chaged value of Fixed pay from 40 to 30 (for
  2. Glide Table where change is reflecting
  3. Spreadsheet where it is still showing 40 (original value)
    Unless change reflects in GSheet, re-calculations cannot be done & output cannot be displayed back.
    Kindly help

Your sheet tab appears to be locked. Are you sure Glide has access to update that particular sheet tab?

We locked the sheets 3 days back and all was working fine untill 2 days back, so don’t think that is an issue. Have unlocked them now. But issue still persists.

I suspect another issue. A team member transferred ownership of the GSheet to my personal ID pooja0402@gmail, roughly the same time that the app stopped syncing with the sheet. pooja0402@gmail was not part of the Glide Team on VenEx. I have since been trying to add pooja0402@gmail to the Glide Team on VenEx but that is not happening!! Pls. see the process am following, yet am not part of the team as yet. Have tried using invite link also which shows Join Team but as faded (not an avtive button): Glide issue- Data not syncing into spreadsheet. Unable to add Team member - Google Drive
Kindly help fix this, maybe after that this may work.

Weird that you see the messsage “could not find that invite”. Have you tried the invite link with another email? Does it show the same message?

We already have 6 more people in the Team & they all joint via this method over the past few weeks.