Youtube doesn't allow to watch fullscreen videos anymore

It looks like, this week, Youtube updated the video embedding. All videos now play in a custom interface instead of the traditional one.

Unfortunately, in iOS at least, the new interface doesn’t allow to play videos in full screen. Even if you use Safari, it says that the browser doesn’t support the feature - my opinion is that clearly, Youtube is forcing people to use their apps.

The official Youtube help says that they can disable the fullscreen functionality.

It would be great if we could have a way to use oldest versions of the embed code, custom embed codes or even a workaround to enable the fullscreen play.

Play a video in a mobile application without the possibility to watch in full screen doesn’t make sense at all. It’s a bit unfair on how Youtube runs the game. ):

1 Like

I’ve yet to see this problem. My app uses embedded links to Youtube videos in a Video component, and they not only play fine, they play in fullscreen. I’m using the app’s editor on a tablet, then the actual app on my phone; it works.

Could you provide a screenshot or video of what happens on your end?

So far, I notice the problem only in iOS/iPhone.

In case you want to check it live:

Yes, I tried your app in an attempt to reporduce the problem you’ve described. It works fine on a Chromebook or Android phone. It even works fine on Windows. Since I don’t have any IOS devices, I’m going to assume its Google’s way of forcing you to use their app, as you’ve stated previously. Well, we can add this to the list of things that describe the Apple/Google relationship. :man_facepalming:t5:

1 Like

Did you also notice that you can’t open Youtube video from the Glide dev side either? It happened today for me. Was there a Youtube update?

It looks like Youtube is strengthening the approach towards user data. If it’s not possible to capture all the data, they will remove functionalities - indirectly forcing users to consume videos in the way that they want.

In my app, I realized that it depends on different aspects like if the user has the Youtube App or uses ad blockers (which is the most apparent reason).

Apparently, we cannot control.

oh:-( nothing in their help section…

Actually, I found I had to make sure all my related software was up-to-date. It now plays Youtube from the dev on my mac (catalina’s new software update).


See, I’m inclined to believe that this is an Apple problem, as I’ve said above. I tried many different browsers, Incognito mode, Private Mode, in the developer environment, signing on as a new user, and still not seeing this problem as its being described.

If those of you are using Mac or and IPhone for your app AND embedded YouTube videos, then perhaps try a different browser? Or, the more obvious, switch to Android? :grin:

1 Like

After a few tests, I found three reasons that contributed to my original problem:

  • Adblock extensions
  • Custom network settings
  • Forcing Safari to request the desktop website

Any of them can change video player behaviour. Having the Youtube App instaled, sometimes can bypass the problem but it’s not guaranteed.

In my case, it was all of them. That’s why it was hard to debug.