Webhooks missing data

Dear all,

I’ve been dealing with this issue quite a few times now, I want to send my data from my lookup and joined texts columns to integromat through a webhook.

This is driving me nutts :smiling_face_with_tear:

But I’m getting no data on Integromat which is weird. Am I missing something ?
Capture d’écran 2022-01-25 à 18.24.45

1 Like

Maybe obvious but have you tried to re-determine the data structure?

If the lookup is from a multiple relation then that won’t work. The joined list should definitely work though.

Yes, I’ve done that countless times but nothing changes…

Thanks for your help tho

Again sorry if it’s obvious but do you have any set column values → clear value that could be front running the webhook? Do you have a screenshot of the setup in Glide and maybe one of the Integromat scenario itself

I’m pretty sure I’ve got this exact same issue. I logged a ticket and I think @Mark & team are looking at it.

When my values show up empty in integromat it’s only when I trigger the webhook off my phone. When I use the builder/web there is no issue. Exact same trigger and dataset. I’ve never logged a ticket before but I feel it could be a bug as triggering it from the web proves there’s nothing wrong with the data itself or the triggering mechanism. I could be wrong and am more than happy to be corrected but it sounds a lot like what you’re seeing too.

1 Like

Are those built on top of any experimental code columns?

My experience is that you should set the button to trigger the webhook to only be visible when the related columns are not empty, it will force Glide to calculate the columns. This is assuming you’re using a button and not in a form environment.

1 Like

Thanks for reporting your issue. In my situation, there’s no data coming up either on the builder or the phone…

Hey @ThinhDinh, thanks for coming in !

No, it’s just relations and joined lists.

While it’s a very handy tool, it looks like webhooks are not 100% reliable (even if it may be one of, if not the biggest asset of our apps)

1 Like

A fix to this should be shipping Friday.

9 Likes

This is most likely because of some lookups didn’t read the data correctly to be pushed to the trigger specially if there are many rows in the app.

The only workaround is to create a glide table and push the lookup column as a data in bacground either via add row or in background fetched in a form
push trigger from that row
then add a delete action to clear to avoid data row count

Hi @Mark. Did this ship on Friday as expected? Thanks

Yes.

2 Likes

I can confirm the fix has worked for my use case. Thanks

@Mark I have a couple of webhooks configured in an app working with no issues, but, the only one that I constantly keep seeing it unstable is triggered when submitting a new item form. The issue is specially with data coming out from calculations or the RowID itself, I am almost sure that is a matter of time, I mean, by when the app send the data some of the calculated values may not be finish, last inconsistency I am facing is with a value that picks the last 2 digits of the RowID and concatenate with the current date, in integromat I am just receiving the date. I strongly suggest to have the possibility of include a delay in the custom action before the webhook is triggered unless you guys may help me in other way.

Thanks in advance!

Hey @Jesus_Valenzuela_Dia

Could you submit a ticket with a small app where you this issue is happening?

That will help us diagnose faster.