Webhook Issue

Hi all. Hoping for a sanity check…I’ve setup a webhook in Integromat to drive an SMS service using Twilio. I’ve setup a few tests from my glide app previously and everything worked fine. However, now I notice that I get a different result in the Params when I trigger it off the app vs the builder (phone vs web).

So the data packet delivered to integromat is different depending on which device it gets triggered from (2 data elements from the web but only 1 from the phone app). Am I losing my mind? Definitely working off the most recent changes (published) on the app. Its breaking my brain as it appears to make no sense.

Appreciate the help as always. Thanks

What specific parameter isn’t being sent from your phone? Is it a value calculated from a plugin/experimental code column or something else?

Hey. Thanks for the reply.

Not an experimental/plugin field. It was a comma separated joined list of phone numbers. I ultimately ripped up the script and started from scratch with the webhook and it corrected itself. Could have been something I was doing incorrectly but felt a lot more like a bug as when i set it back up again it was the very same setup.

I’m unsure if you use Twilio or not? I’m using it to get around the native messaging issue like I’m sure plenty of others are also. It works fine when I send Integromat a list of numbers, split the list using an iterator and then fire off the messages using the Twilio create message module. However, the final piece thats not possible on Integormat is the use of the Alphanumeric Sender Id. So I cant overwrite the actual phone number with the name of my App which is a real shame. I can do it easily if I use Zapier but thats pretty expensive vs integromat. I’ve put a ticket in with Integromat to ensure I’m not missing something and hopefully they can correct it to facilitate if the functionality isnt there already.

Possibly of no interest to you! Apologies if its not but a few hours effort figuring out what the limitation was and I know others might search the keywords above for someone whos been down this road previously.


Hey. Just FYI - I use Integromat + ClickSend and that allows the Alphanumeric Sender ID.


Thanks so much. Sounds perfect!

1 Like

Thanks for sharing this use case, I have used Integromat + Twilio a few times before but have never touched the Alphanumeric Sender ID.

I can confirm I’ve set this up now and it works very well. Thanks for keeping me on the best path. Many thanks.


Great. Glad you’re working!


Just circling back to this for input as the webhook still seems to be unreliable.

I’m sending a comma separated list of numbers (joined list) as a parameter in the webhook. But it doesnt always send. Or it stops sending for some reason. If I look at the inbound payload in Integromat (Glide Listener Module) the list of numbers can be missing. Then I play around a bit or set up the trigger again from new and it works for another while. Initially the issue was also manifesting itself between the web and app. I cant figure out whats going on to be honest. Or why. Payload is the same throughout by the way as I wanted to test vs the same dataset.

Anyone else seeing that type of inconsistency??? I appreciate this is a bit grey so I’m not expecting someone to jump in with an answer. But who knows? Maybe its been seen previously. Thanks in advance as always.

I’d be looking for any volatility at the source. For example, how is the joined list generated - and in particular - is it generated as part of the same action sequence that triggers the webhook?

If it is, it could be that the list isn’t always generated before the webhook part of the action fires off.

Just a thought…


The other thing that might be worth checking is if you have row owners in any of the tables involved.

1 Like

Ok great. Thanks. Will check those out and see if it stabalises. Appreciate the input.

If you’re having a button to trigger the webhook, set it to be visible only when the list of numbers is not empty. That will force Glide to calculate that column.


Thanks everyone for the input. Its great to be able to throw out a problem and get feedback.

As FYI - I believe the issue is related to bad data. As noted above, the parameter being lost is a list of phone numbers. Ultimately these are the folks that will receive an SMS via ClickSend. I was storing the numbers in the format +9 99 999999 etc which I think was causing the webhook to fall over for that specific parameter value. I’m entirely sure why but when I changed “+” to “00” it is now stable. The reason I wasnt sure until now was that when it was a single value in the list it worked fine. So it seems to only be an issue when I have mutliple values. And the impact was for the webhook to just drop that parameter completely (but still send/receive the other parameters with no issue).

I had a look for a plugin that would convert numbers into proper phone numbers but currently none in the available list from glide. I assume theres one out there somewhere that I’ll need to look into as a means to sanitise the numbers prior to sending them to the webhook. I had never previously noticed but when storing the number in the google sheet, the phone numbers are prefixed with a ’ which prevents sheets from seeing it as a formula. I did think that maybe this was seen a special character by the webhook and might be causing it to just drop the parameter.

Anyway, again I’m just documentaing this to try help others. Frustrating when theres no error or anything. Just no value on the other side when the data gets sent. A few keywords included above to try and get a hit for someone if it does happen for them also. Hopefully some of my assumptions are accurate but the truth is I’m not sure.

One more thing that might be worth a try.
Instead of sending the numbers as a joined list, you could try sending them as a collection as part of a single JSON object. It would be easy enough to construct that using templates, and might be a little bit more robust.


Interesting. Thanks. I’ll look into that if I see any recurrances.