View details not working inside a inline-list

I am writing the data from a form submission into two tables

a. the default table what the form writes into
b. using the action to make a copy of that data into another table

Am adding that second table as a source to the inline list in a tab - but when I click on the image it gives an “ERROR” message

If I link the original sheet what the form is writing into then that’s working fine.


This may not have anything to do with your action settings, but a bug in Glide this week.

You can try:

  • Refreshing the editor to see if it works.

  • Inserting a helper sheet with a random column name into your data, refresh the data, refresh the editor and check again to see if it works. Then delete the helper sheet.

@ThinhDinh Could well be an issue as well. Because i even went ahead and created one sample app from scratch and did the exact same steps and things were failing again. I did try refreshing the editor, closing and opening the app from scratch, retrying from phone.

When you s ay helper sheet - you mean just point the tab to a diff sheet and check if things are fine there and then repoint it back to the sheet which is giving me problem? If so let me give it a try.


Just add a random new GSheet with a couple of dummy columns, and sync with Glide.
At least, that’s what resolved the issue for me a few days ago.

1 Like

Yeah I have this issue with seemingly every new Sheet I add into the database for one app. I followed your comment a few days ago and that solved the problem for now.

@ThinhDinh @Darren_Murphy - The update is that this trick worked. I pointed the list to the original sheet and then saw that the flow I going fine and then came back and linked it back to the new row and it’s all fine now with no ERROR message.

Not sure if we should call it as a workaround but if its something that can be fixed then i presume the dev should try looking into this.


1 Like