Unable to set User Table source for Private > Users in User table

I have an app published with privacy settings as : Private > Sign in for Users in Users table.

When I send an invite to a user from Share > Invite, they are able to sign in from the link generated in the email.

However if they go directly to the App, and sign in with the registered email, it gives them an error saying : The email address doesn’t have access to this app. Please try another.

When I try to set the Users Table in User authentication to fix this, it doesn’t give me the ability.

Changing Privacy Settings to Private & All Emails in Table, sign in works.

Trying to understand the difference between these options. What is the expected behaviour in the first case?

Thanks!

I’m wondering if you have a Users table set up. When you head to Settings > Users & Authentification, is the source of the Users table set to ‘None’ or to an existing table’. If it’s set to ‘None’, then you could set up your Users table and see if that fixes your issue.

When the Users table is set up, it should look like this with a small turquoise icon:
Screenshot 2023-10-18 at 12.37.03

When you send an invite and the user clicks that link, does that generate a row in your Users table? The link might have a pre-defined flow to allow users to bypass the private settings if their email isn’t already in the Users table.

An alternative way is to create a combo action.

  • Add a form to add users in your app.
  • In the on-submit action of that form, send an email to the email address you just added to invite them to the app.

That way, the email is surely already in your Users table before the user reads the email.

1 Like

I do have Users table set, but when I’m unable to change the Source when I set Privacy > Private + Sign in for Users in Users table.

Changing Privacy > to Private + All Emails in Table, then selecting Users is the only option I’m able to select.

I have no issues with allowing access to users, I’m just trying to understand why I’m unable to set the Source table when I select;

Privacy > Private + Sign in for Users in Users table.
The above setting to me implies being able to select the Users table but it’s not letting me do that.

Maybe I should have worded the question differently.

Adding a video to better explain the issue;

Thank you for the video. Have you configured your Users table? Do you at least have an email column in there?

Yes, I have Name & Email in the Users table.

Can you share a screen shot of what you see after you click on “Edit User Profiles” under Settings → Users & Authentication"

I’m unable to click on the Edit profiles.

Also, I’m on the free plan. I’m sure this is a combination that is probably not allowed, but I couldn’t find documentation anywhere.

Somethings not right. Being on a Free Plan makes no difference, you should be able to select the Users Table as the source of your User Profiles.

If you create another App in the team, are you able to replicate the same behaviour?

1 Like

Okay, looks like I needed an Image column too. Figured that out when I went to User Profile and selected the Users table as the Source. It gave a message saying Image is required for Users to work properly.

Would have been nice to have this message in the other section too… been scratching my head on what I did wrong :confused:

2 Likes