Unable to add input components to a Details Layout

I’m quite sure I’m having a brain-fart here, but I can’t for the life of me figure it out.

I’m building a form on a Details Layout, and trying to add a Choice component.
The choice component appears in the list of available options, but when I select it nothing happens.

When this happens, I know it usually means there is no available column to write to. But that is not the case - I have User Specific Columns ready to take my inputs, and I have a single row of data in the table.

The one thing I did notice is that most input components are missing from the list:

ie. No number entry, no text input, image upload, etc.
Of the ones available, the only one I can get to stick is the comments component.

It’s not like I’m learning to do this for the first time - I do this multiple times per day, every day. So I feel like I know what I’m doing, but…


Have you been able to solve this? Are you building a custom form?

1 Like

Yes and no.

Let me provide a little more context.
Yes, I’m building a custom form. I’m actually replacing a native form that was built some months ago, before compound actions became available.

My scenario:

  • User is presented with a button
  • When the button is tapped, a custom action sets a USC and then does a Link to Screen action
  • The target of the Link to Screen is a separate table (a Glide Table)

This is where I started building the form, and hit the problem.

Weirdly enough, it seems to be related to the actual table itself. After much trial and error and messing around, I eventually decided to create another (identical) table and try that. And it worked??!!

So yes, the problem is solved. But I’m at a complete loss to explain why it didn’t work the first time.

1 Like

No idea why that didn’t work the first time either. Upon reading your post I can only think of the reason that it didn’t have a row to populate, but seems like not the case.

I believe even when you don’t have a row to populate, the entry components would just be greyed out right?

1 Like

Yeah, that’s what usually happens.

I have actually bumped into a similar scenario before - where some input components aren’t available - but never really paid much attention to it. I think I’ll pay more attention now, because I suspect there’s a bug in there somewhere.

1 Like

I had this happen once before too and it was due to the fact that the tab my screen was pointing to had no data in it other than a few User-specific columns. Once I added some regular columns and data, the components showed up. Make sure you’ve got data in the destination sheet and not just the one being used to generate the choice lists. A browser refresh may be needed to get things to show up after making the changes.


I did try the browser refresh early on, but that didn’t make any difference.
The thing that gets me is that the second table that I created is basically identical to the first.
Same columns, and just a single row of data.
One works, and the other doesn’t. Go figure.

There must be a “minimum requirement” for some components to show up. It would be good know what those are and it would likely very easily solve this issue (i.e. choice component only visible when sheet has “x” rows of data/columns, etc).

So I just did a quick test…

  • Created a new Glide table, with just the 4 default columns
  • Added a dummy value in the first row in the Name column
  • Created a new tab, and set that table as the source
  • Switched it to a details layout
  • Opened up the component picker, and got a full list
  • Added a choice component, worked as expected

:crazy_face: :rofl:

1 Like

Be careful with Link to Screen, I have already had unstable things.
I don’t know if this is the cause of your bug.
for example this bug:

1 Like

mmm, that’s interesting, although I don’t think it applies in my case.
I can’t recall if I started by copying the original component, but even if I did I know that I definitely tried it a number of times by building a new component and action from scratch - and it still didn’t work.

But I think I agree that as a general rule it pays to be wary of copying components that have custom actions attached.

1 Like

Sorry, good luck :smile: