Time zone settings glitch

I have a dynamic search that inserts a timestamp to determine which is the latest search input. Been working well for months but now it’s inserting a time that is two hours ahead instead of right now. Could it have something to do with time zone settings? My time zone is GMT+2.
Not sure what the issue is or how to fix it?
Same issue on laptop and phone so it must be a system issue, maybe related to new updates

Check the configuration on your Date/Time column, specifically the “Respect time zones” setting:

This is a new feature that was recently added. I don’t know if it’s causing your issue, but it might be…

Okay neat, must be that, i’ll check now👍

I cannot see that checkbox at all. Cleared history, cookies, logged out and in, created new column. Still doesn’t display the checkbox for that??

Okay, is the table connected to a Google Sheet?
This feature only applies to native glide tables.
If that’s the case, it’s not the source of the problem.

What happens if the time value of this new feature is written into a spreadsheet or vice versa? Have you ever tried it? :thinking:

That can’t happen, because if the table is connected to a Google Sheet you won’t have the option.

Sorry, I was just asking myself.

It is connected to a sheet. So what else could it be?

@Mark might this be related to the issue I had where the local time had a Z appended to it instead of being converted when sent via webhook?

I just noticed that while the Tab is connected to a sheet, the column is User Specific, so the data is only on the data editor/table not on the google sheet. Maybe they haven’t catered for that yet since the upgrade?

This is how i’m using it at the moment, see image attached.


Could you submit a support ticket with a narrated video of how to reproduce the issue?


I literally am just using a date time column (set to user specific).
I use a button with a set column action that writes the current time into the date time column.
The problem is that instead of writing the exact time for right now into the column, it’s writing a time that’s two hours ahead (a time that hasn’t happened as yet)

I think the two hours difference may have something to do with my timezone GMT+2
But there’s no fanciness involved. It’s a straight forward click button to add the latest time in the column. And it all worked well up until very recently.

I’m certain it’s to do with an update from glide. because i haven’t changed anything on the app in a while now and i just noticed this glitch yesterday.

Hope that helps.

Please provide a support link or submit a ticket so Santiago/the support team can look further into your issue.