Time Issue

I have attached a form within my glide app to a zapier trigger. When a person clicks submit on the form, the Zapier sends a message (an email) to another person/company that the form has been submitted. Unfortunately, in that message/email, the time appears as mentioned in the image attached. How do I convert that time format into something that is understandable to a normal human being? Just to mention, the time does appear in “June, 23rd at 4 pm,” for example, format in my glide spreadsheet, but not in the email.


You can try creating a template column that replicates the date. When you do that, it actually “locks in” the formatting, so if should preserve the formatting when sending the email.


Thanks for replying, deeply appreciate it. Will you please be more detailed on how do I do that? How do I create that template column? and it will in glide spreadsheet, not in Zapier?

Add a new Template column to you table. Give it a value such as ‘X’. Then replace ‘X’ with the column that contains your date. I’m not sure if it will work for your problem, but it’s something to try.

I tried that. Didn’t work.

Can you show us how you’re setting that up with some screenshots?

1 Like