📆 Date/time formats

Glide can now format your :calendar: date and :alarm_clock: time columns, in the app user’s language, very similar to how number formats work:

For the time being, you still need to put your date/times in your spreadsheet in US format (month/day/year), but we will soon make that unnecessary, too.

Please let us know what you think, and if you run into any issues.

21 Likes

Another super addition, these glide updates are getting addictive

2 Likes

I just found it in an app I was finishing this morning. Timing was perfect, and it worked like I expected. Thanks for all you do for us.

1 Like

Thanks, Mark!

Nice! One less formula I need to add To my spreadsheet. Keep them coming! Any thoughts on including a current time date column in the data editor?! :wink:

3 Likes

Excellent. Can we make Glide columns that duplicate the data in a Date/Time column and format that column the same (like using Template or If - Then - Else)? If we want two different columns with different visual formats in the app. Or is there a way to change date formatting in the components themselves yet?

@John_Cabrera Not yet, unfortunately.

No problem. This is still quite epic. And a stepping stone for those kinds of additions, I’m sure.

Can you explain this one a little more? I looked at your feature request, but I’m not sure I understand how it would work.

Like a “single value” column but it outputs (and updates) current date time. Doesn’t get pulled from the sheet…Glide provides.

How would you use it?

Hi, I recently updated my date and time column and everything worked great, except the data isn’t showing up on the downloaded app on my phone. It’s viewable from the app on my desktop, but not the one on my phone. I already deleted it and downloaded again, but nothing.

Any ideas why data isn’t showing? Here are some screenshots…

@emilio Could you share your app, please, and tell me how to get to that screen?

Thanks @Mark. Here’s my app demo-english.glideapp.io. To get to that screen go to the Messages tab > “New Mexican Restaurant” post.

I see. I’m guessing this is because Safari can’t parse the date you have in your spreadsheet, but Chrome can (we’ll fix this problem soon). What’s in your sheet in that column?

1 Like

Alright, no rush. Just wanted to make sure there wasn’t anything wrong on my end. It’s just dummy data, nothing critical.

Emilio, I had that problem as well. Check your date format in your Google Sheet, it should be MM/DD/YYYY… I had it as DD/MM/YYYY and safari, for some reason, couldn’t read it.

1 Like

Thank you @Daniel_Lozano. It makes sense, but the date was generated automatically.

It’s an old post, I’m going to upload a new one and see if that changes anything.

It happened to me as well… for some reason, after selecting the date column and reformatting it to MM/DD/YYYY, it got fixed. But this is definitely something that shouldn’t happen!

Ok, let me try. :+1: