Subdomain and https

My app’s URL: bespokeyucatan.glideapp.io

So, my domain is in Godaddy. It has SSL, but as far as I understand, the subdomains don’t have SSL.

I’m following Glide’s and @david 's instructions, however since I’m in godaddy instead of Google Domains, I’m a bit confused.
I want the app at app.cancuntour.app, however there’s an error and I can’t find how to make this work.

Any help? TIA.

We provide SSL for you, it just takes about 30 minutes.

Hi @eltintero

Your dns configuration is incorrect. You seem to have an A record pointing at 107.180.44.155 (this is a GoDaddy parking server). You need to delete that record before attempting to set the CNAME.

Lastly your _glideauthid TXT record is set to “abc123”, not the value provided to you in the builder.

Point 1 taken and changed.
Point 2… that’s what I understood from the instructions link, I got it from @david 's link https://codepen.io/dvdsgl/full/qerewL

You’re supposed to enter your app URL and auth ID in that tool, and then it produces the correct records. abc123 is a placeholder. So is app.mycompany.com.

Please open that tool again, and enter your custom domain and auth ID.

So, are these the right records then?
I deleted the A record

The TXT record looks right, but not the CNAME. You have replaced custom.glideapps.com. with bespokyeyucatan.glideapps.io but that is not meant to be replaced—it should actually be, literally, custom.glideapps.com..

Ok, now from Glide’s side, it appears all is good.
However when going to app.cancuntour.app, the following screen appears.

From your previous comment, I assume I should just wait 30 mins for YOUR ssl to take over this subdomain?

Yes

gotcha.
Thank you @Jason and @david

Sounds like you got it, but I still made a video! I will add it to the documentation.

Thanks David!

1.- custom.glideapps.com. The last “.” is still part of the value, correct?
2.- https://app.cancuntour.app/ is still not loading. I’m sure there’s something to do with MY SSL…

Your app works for us—you may have old DNS cached.

Also, really nice app!

Thank you! Hopefully this works out and we become a good customer of yours!

2 Likes

@Jason @david Facing HTTPS:// connection not secure error.

  1. glideapps is setup with www. covid-relief. in
  2. Godaddy domain forwarding covid-relief. in
  3. covid-relief.in and https://covid-relief.in give the “your connection is not write error”
  4. Also, covid-relief.in, http:/ /covid-relief. in, https:// covid-relief. in it shows the loading screen and gets stuck

Please help ASAP

It looks like your certificate is set up for the www subdomain. Does it need to be changed to work with the whole root domain?

I don’t have much knowledge about it. I want the certificate to function on the following so that there is no error or SSL warning on any. Can we please do this ASAP?

covid-relief.in
https:// covid-relief. in
https://www . covid-relief .in
http:// covid-relief. in
http://www . covid-relief .in

My domain forwarding, DNS settings, emails, and all links are in perfect settings and cannot be changed.

Can we please do this? It seems like it can be solved only at your back-end.
Please reply asap or mail at hello@covid-relief.in

Thanks Jeff.

If I give you a SSL certificate (wildcare or specific), can you install it?

You’ll have to ask the Glide team for help with that, or maybe somebody else has some input. I can’t do anything as a fellow user and I honestly don’t have any experience setting up a domain to work with Glide.