Stuck - cannot use Lookup columns in Inline list (video to explain)

Argh! I have made a Home Page with an inline list - using View Details and 'independent screen configuration per item" ticked yes. the inline list values come from a simple 2 column thing in my UI sheet (i.e. 'My Cards" and an image, etc)

When I try to edit and design the details for each area, I want to pick the relevant sheet / Glide Table (e.g. to get ‘My Swipes’ I need ‘Swipes’ and then filter by email is signedin user). I can pull in the data! Yippee…

But when I want to display the data nicely, such as a card title and the image, the columns I need to access are not available. In my video you can see that I have a card rel (connecting the swiped card to the Card), and then look=ups to get the Card Title and Card image. I can see them in the sheet… but I cannot select these options for the Inline List.

I also have no Rels I can reference as the initial component in the previous screen, the ‘home’, was merely a UI.

Each of the 4 boxes on the home would point to different areas:

  • My Cards = Cards sheet
  • My Swipes = swipes sheet
  • Chats = chat tab ideally
  • Networks = network sheet

I am stuck :frowning: so any help would be greatly appreciated! thanks, M

Switch it to a single relation and it will work.

1 Like

uncheck “Match multiple” , relation have to have only 1 match for lookup to work :wink:

1 Like

Sadly not…

  1. in Swipes, if I have Card Rel = 1 match, then the lookups are empty
  2. with OR without 1 match or multiple, the Lookup columns still do NOT appear in my inline list as values


Any other routes? Or is this a bug? I hope I am still missing something easy (and I had tried the single - multiple values, having did a search beforehand – but worth repeating the method!)

Thanks, M

I have the same problem in my new Networks area.
I am using a Glide Table.
If I use Multiple for a Rel, then values for lookups are populated (but I cannot see them)
If I use 1 match, then I get no values in the lookups, and I still cannot see anything

It should work. The reason you can’t use a multiple relation is because you could potentially have 1000s of matching rows resulting in a lookup array with 1000s of results. You can’t put an array of multiple values into a title or any other setting that can only hold a single value. If your multiple relation is linking to a single row, then there is no reason that a single relation shouldn’t pull back that same single row.

First set it back to a single relation because it has to be a single relation. Once you do that, refresh the browser to make sure that it recognizes that change. If that still doesn’t work, then I would recreate your lookup columns. It should definitely work.


Yes - this worked (and the explanation makes sense too).

I closed down the browser, then deleted the lookups. Then set rel to be 1 match… and when I recreated my lookups they actually worked.

Thanks, @Jeff_Hager !

1 Like

yes, you are missing understanding how relations works, it looks for values in columns that matches values in parent column. If lookup is not bringing back a value, that mean there is no value for that request, or browser did not registered yet… you need to refresh if data is being feed from google sheets it takes time or action for Glide to refresh. also Gsheets when open doesn’t work fast… so there is a double accumulation delay in communication between Glide and Google

1 Like

Similar question to above.

I read through the thread and understand that the rel column cannot allow for multiple matches.

My issue is that I when trying to serve up data from a lookup column within a component (any type), it shows the data in the table as well as in the data preview in the right hand side when selecting which column to use in that component… But then when I select that column, nothing is served up within the component so the component just disappears.

This only happens with some of my lookup columns and I’ve rigorously gone through ones that worked and compared with ones that don’t and don’t see anything different. I mean, there’s not that many steps involved…

Data is in Glide Tables and I’ve given this a lot of time so I know it’s not a latency issue.

Could there be any other cause beyond a lookups’ relation value allowing for multiple matches?

I really appreciate any information.


Do you use Row Owners in any of the tables that the Lookup column would be pulling from?

Thanks for the reply here.

I do not…

So you don’t have row owners in any related tables? Can you show us some screenshots or a video of how you’re setting it up?

1 Like

I do not. Should I be?

Okay, here are some screenshots showing how the lookup and relation columns are built, as well as how it’s acting in the front end component:

^ This is how the relation table is set up. The ‘Host_email’ is a direct input on a different table filled via form and works as expected.

^This is the column in the table with the lookup: the lookup is working as expected pulling in the Host Phone based on the Host email rel.

^This is in the front end where you choose a column to tie to a component: you can see the lookup feeds through properly here as well.


The component (regardless of type) remains empty in the front end and therefore does not get served…

I hope this helped a bit… Again, thank you so much for always being such a valuable resource.


You show the “Host Phone” column here.

But here you are showing the “Artist Phone” column. Is “Host Phone” not empty on that specific row, since I don’t see it in the dropdown.

Nice eye! Here’s the right screen shot. Same problem though:

^host phone at the bottom

That’s weird. Do you mind inviting me or one of the experts here to your team so we can look more into this problem?

1 Like