Strange behavior with camera photos

I have an app I’ve used for a while. I did some updates (added some text fields and a yes/no choice). This app asks users to enter some texts, take a photo more text another photo more text, and one final photo. The strange behavior is that when it comes to the 2nd photo if you use the photo library, things are fine. However, if you use the phone’s camera, the app resets all previously entered data and doesn’t include the photo. So the user would have to re-enter the data and first photo but only use the library for the second photo. Things work fine is they use the camera for the third photo. All three image picker input fields are set up the same. Trying to understand why this is happening and more importantly how to stop it.

If you can reproduce this, please submit a ticket here.

Since I needed to assign it tomorrow, I took out the second photo requirement and everything worked. After I got your message, I made a copy of the app and added back in the second photo. It seemed to work. So I went back to the original app and added the 2nd photo back in on that app and IT WORKED. I had tried that last two nights and I still got the error. So I guess it is all good now.

1 Like