Sheets won't sync anymore

My app’s URL: dtw2l.glideapp.io

Hello! I think I’m actually going mad trying to figure this issue out.

I have a really simple app. I haven’t plugged in all my data yet, have just been getting all the various functions working with some placeholder info. Everything has been working perfectly until suddenly now where I’m having a weird glitch where it’s stopped syncing properly all of a sudden.

I deleted a sheet I didn’t need anymore (it’s not being used by any of the tabs) and I’ve added a new sheet. However, it doesn’t matter how many times I press ‘reload sheet’ or if I fully refresh the window, or close and reopen Chrome, it just will not work in Glide.

The new sheet shows up very briefly in the data section, before switching back to the old view after a second or two. I’m at a total loss for how to fix this. I’ve searched everywhere, I have no weird functions in my sheet, and I just cannot figure out what’s happening.

In the below screenshot, you can see the sheets that should be available – the one I’m having issues with is the ‘Home’ sheet, but I’ve also tried adding other new sheets to test and nothing works.

In the below screen recording, you can see what happens when I try to reload the sheet:

Anyone know what’s going on and how I can fix it?

I fixed it! Found deep in the forum somewhere that sheets won’t work / show unless there’s data in the first two rows. I typed in some gibberish and now it works.

Such a simple fix but doesn’t seem to tell you this anywhere!

Odd. In my experience, having a single header should be enough. Maybe it was a temporary glitch and adding more data to the sheet fixed it.

@laracb If there’s any way you could make this happen again and let me know I’d be very appreciative.

Damn I am having the same issue again today with a different page, but this time adding in data to the first two rows hasn’t fixed it!

As you can see in this screenshot, I’ve added a sheet called “About The Project” which has some random test data in it: https://d.pr/free/i/RIiqCs

However, when I try to reload the sheet in Glide I’m having the same issue where it shows up correctly momentarily in the data tab and then disappears, see screen recording here:

https://d.pr/free/i/wzFgow

Absolutely no clue how to fix this issue! Any help would be hugely appreciated. It’s really stopping me from progressing at all with Glide.

Cheers,

Lara

I’m looking at it, thank you for reporting.

If you reload Glide in the browser, does the issue go away?

Reloading in the browser (both Glide and the sheet), or closing and reopening Chrome itself does nothing unfortunately.

However, it seems to have fixed itself after a while once I start adding data to another existing sheet. I wonder if it’s just a weird syncing delay?

Although perhaps not because it does seem to recognise that there is new info (when it displays it for a few moments).

Very strange!

Next time this happen, please contact me directly via PM and don’t change anything if that’s possible. I’d like to get to the bottom of this. It’s probably affecting other people, too.

Sure thing, Mark! Will do!

I am having the exact same issue at the moment! Could really use some help. I’ve tried everything laracb has as well.

Could you please share your app with me?

Strange, it started working again!