Sharing Button appends instead of custom domain

Hi all! I’ve been lurking for a few weeks while I’m building my app and I’m starting to share it with friends and family.

I’ve subscribed to the PRO plan and have successfully connected my app to my custom domain.

I’m building a custom string so that users can share a link to something they’ve created, ie. "Check out the thing I made using the appname app → url to item.

However, the text that is shared also includes, which I’m not telling it to do and at any rate would preferably be

Would love some tip sand insight as to how I can fix this.

Can you explain a little more how you are sharing the link?

Which url did you use to initially install the app on the device? That is the url that will be used for share/deep links.

1 Like

I think I used the original, will uninstall and reinstall using the custom domain and report back!


Yes, great insight @Jeff_Hager! Uninstalling the app and reinstall from the custom domain changed it.

The second part of my question (but not as critical), is there a way to opt out of including this link?

What I’m sharing is a string that is built in google sheets and the URL is not an app url, it’s actually a link to a file hosted on Google Drive (for now). To clarify, the URL is part of the string and concatenated in google sheets.

1 Like

How are you sharing it? A share action? Where are you sharing it to?

Yes. A button for which the action is “Show sharing options” and the data is a column of strings.

I’m not experiencing the same thing. For me the share action only shares the column value and nothing else. I tried sharing to gmail, sms and a note taking app. All of them only shared what I intended to share. My guess would be that the sharing sheet on the device you are using does that by default and it’s not tied to Glide. I use Android. Have you tried other devices, like IOS and Android. Have you tried sharing from other non-glide apps to see how they react when sharing content through the share sheet?

I’ve only been able to try with Android. Perhaps you are right. I changed the button to copy the link instead for now.

I’ve tried sharing with other non-Glide apps on my phone. They include links, but it’s hard to tell if that’s the behaviour requested by the apps. But, for example, CastBox does something like this
“I’m hooked on Podcast Title Name on Castbox. Check out this episode! Https://

And there’s no other links appended to that.

I’m not sure what to tell you. I have a Motorola, which is mostly plain vanilla android. If you have a specific app you are sharing to, I can try something similar and see what it does for me.

I definitely appreciate the help and you got to the reason why it wasn’t using my custom domain, which was the bigger issue for me. I’m ready to move on to the many other things on my list! Thanks!

1 Like

From what I understood when you share something and give it the cell’s data, the app will only share that data, that can be anything, can be just one letter, one number, or a poem, or a link, anything.

So if your app is sharing a link to your app you are probably telling it to do it somewhere in your ‘code’

No this seems like the new intended behaviour now, I can confirm the original post.

So the system adds it’s own subdomain to whatever data you are sharing?

I suppose that if you are pro you don’t get any glide subdomain, right?

I’m not sure about the domain part but it adds the app link automatically when I try to share using show sharing settings.

1 Like

I can confirm that once you have your own domain w/ the upgrade to the pro plan (but I realize there are now new plans w/ new names), the url will be your custom domain, but only if the app was installed from that custom domain.

1 Like

You have the option to use a custom domain. You also have the option not to use a custom domain :stuck_out_tongue_closed_eyes:

I can confirm that the sharing button appends a deeplink/app link to the contents of the cell. Even I would love to opt out of that because it’s undesirable at times.

1 Like

Yeah I definitely want to have an option to opt out because sometimes I just want to share the text.

Also when I tried to share to Facebook Messenger, only the app link would appear.

1 Like

Here is something i found out on accident the other day. If you want to use the addthis share buttons, redirect all of your DNS through cloudflare and then turn on the AddThis addon. I was actually surprised to see that it works also on google sites pages (like the web version of my Virtual Mall App) which is where i originally turned it on. Then it crept over into my subdomain so I turned it off for the time being because it is currently restricted to community members. Nevertheless, it works and it carries the subdomain. hope this helps someone.