Row not being deleted

Hello, I have come across something which is really frustrating me. I was trying to record data in different glide sheets to see if its working. After seeing it works fine, I now try to delete those rows, they get deleted in that instance but when i refresh the page or go back to dashboard and come back, those rows which i delete come back. Its a big project and i have been working on it for a month and it has never happened before. I have tried restarting, clearing cache and browsing data, and its still the same thing, deleted rows come back. any tips to get over this? thanks

Are you deleting the rows via the Glide Data Editor?

There is a known issue with this at the moment that Glide Engineering are aware of, and are working on a fix.

Thank you for your response and Yes, via Glide Data Editor. Can I just ask is this a new issue, or was it there since beginning? as I never faced this problem before altho I used to delete data via tha data editor.

It’s always been a little bit flakey, especially if you are deleting many rows at once. But it’s gotten worse recently. Hopefully it will be fixed soon.

fingers crossed, its never happened to me before so found it really weird, thanks a lot for confirming.

Are all the GS updates\inserts\deletes delays and other problems better in pages?

Same computation model, same backend. I don’t think that would be any different.

Is it fixed for you ?
I still have the same issue … I tried to delete in the app, in the data table, in the Google Sheet and it is always coming back !!!

So your data is in Google Sheets and once you delete it, it always comes back? Can you reproduce the behaviour in a Loom video?

Hi ThinhDinh,
It seems that finally I found how to fix it.
I had several windows open on 2 different computers with the GoogleSheet, the glide interface and the app opened.
I closed everything and open only one, after that when I deleted directly in the layout, the data disappeared and didn’t come back !

1 Like