Old data showing?

Guys, i have deleted rows from my google sheet that still show up. What can that be? What can I do?

The data is in the data editor of Glide but not in the Google Spreadsheet?
But how do I delete rows in the data editor?

I assume you have hit that refresh button a few times and shut down, and logged out of the Glide Dev environment, then back in again. Also refreshed the browser. Just making sure you have tried all of that.

I’ve had this happen before too…I had to delete all records with that email address in order to clear the issue. I didn’t document the issue at the time because I thought it was an isolated event. If it happens to me again, I’ll be sure to document.

1 Like

@erwblo Could you please share the app with me, and tell me where you see the old rows?

This is what happened. I copied a spreadsheet, used that as a starting point for an app. Then started deleting rows i didn’t need, so they weren’t in the Google Sheet anymore but did show up in the data editor of Glide and in the app. I had of course tried refreshing stuff, but not - as @George_B suggested - sign out and sign in again. That did the trick. Now all is good again.

I also experienced this beha ior lot of times, to not say always. There’s a delay when deleting data between the app and the sheet, maybe due to cache management?

Having the same sort of problem now.

This is the Google Sheet

This is the data editor

OYO George Hotel has a double entry in the data editor.

@erwblo @Robert_Petitto @Christophe_HK Next time this happens, would you mind PMing me right away with a link to the app and telling me where you see the old/duplicate data?


will do!

1 Like

Will do!

1 Like

Will do too!

1 Like

Done ! In your inbox @Mark !

Some data still appear in the data editor, but they are not in the gsheet. Several refreshes after, they’re still there. This problem is only reltive to the Glide environment : the installed app does not show these old data.