Restrict Information for Certain users

I am using the Personal Task Manager Template and i wanted to get a question answered that i have been just put at a stop in my tracks. When i put filter @email is for sign in user… it makes everything goes blank… and if i click Add a task or project it will let me fill out the form and when i click add it only populates on the SHEET not the app it still says there are no task or projects, but if i cut my filter off completely it appears.

The issue im having is im creating this app for multi users i don’t need them being able to see or edit other peoples personal tasks or goals. Please help i have tried multiple ways and multiple filters. When i edit or delete something it does it for all users. Help please :slight_smile:

Are you using the Email Special Value to write the signed in user’s email to the sheet? Is your filter looking at the correct column?

How do i set up the email special value? The issue I am having is users are able to change other users information while being signed in under their email addresses. I do not have a sign up sheet or anything. I shared the app with three of my firends and they are all able to change other peoples items. I then tried to filter by adding @email by user sign in or user not signed in and they informed me it went blank on there screens. But when they fill out the form it stays blank on their screens but it populates on my sheet. The two Tabs that it does this on is the Task tab, and the Project Tabs

Ok, I have to assume you are using Public with Email for the privacy setting. When you create new records, what’s in your email column in the sheet? If you are not using the Email Special Value, then I assume the email column is empty.

Here’s some info:

https://docs.glideapps.com/all/guides/quick-starts/intermediate-techniques/per-user-data

https://docs.glideapps.com/all/reference/special-values/users-email-address

1 Like

Thank you so much i watched the first video and but not the second way let me see if it works!

It did not work, im not sure but when i type a item lets say “Go to the mall”. It shows up on all users apps… I put signed in users or no signed in users or special values it doenst work. No matter what i put i watch both these videos and did it exactly verbatim. there must be something broken. I been working on this for hours all users are able to access the same personal goals and task list and delete it as well not as their own individual logins… How do i make that unqiue to each user?

Do i need to redo the form from scratch? i am using Glides template im not sure if that has anything to do with it?

You still haven’t mentioned what’s been written to the email column in your sheet.

email column is blank no emails

Ok, on your add form, did you add the email Special Value component and point it to the email column?

Thank you i think i did it exactly has you said and now it working!

1 Like

Hey Jeff im having the game issue with my pie chart? ( personal budget tracker ) i add an expense button when i add and expense it change for everyone as well but i cant seem to figure out how to make it where the pie and the chart only changes for the user signed in applied the same mthod but no luck

yes

Glitch? It’s not working I been working for the last two hours

Can you change you email column heading from ‘@email’ to ‘Email’? I wonder if that’s causing some issues.

I tried @email still same issue no change

My Task Sheet even though I type @email the Task sheet brings up a A sign next to it doesnt show up as email is user sign in or not… it wont populate it as such.

You’re using special characters in a column heading and keep calling everything @email.
That’s confusing to me. I would advise against using special characters in headings. Make sure your column heading just said ‘Email’ without the @ symbol. When setting up the filter, you see an @ symbol, but that’s just an image icon telling you that it’s a column that contains emails. Select the email column for the filter. If it’s still not working, then we’ll go from there. I want to eliminate special characters as the cause of the issue.

Copy that stand by

1 Like