Relation not showing up

Hi there,

So I am currently building a section in my app but am struggling a lot. Essentially someone submits a forum to a certain person and then that person should be able to read this forum. I have it set up so columns have role owners so only the person who submitted and the person it was meant to go to can see the data. I then have a relationship set up to take the person who submitted the informations email and then look them up in the User sheet to get there name. I then lookup this column so I can have the person who submitted the forums name appear on the title and image on the list view of the app. All the formulas work perfectly but for some reason the app will not transfer over the name from the google sheet (It just shows up blank) Also randomly it will only show up on the user is was assigned to rather then both the user it was assigned to and the person who submitted the forum. I have made both the people role owners in separate columns of the google sheet.

I am honestly not sure what is happening as I feel I am doing everything right but for some reason it is not working.

Please let me know what you think?

A few screenshots to show how you have your relations and lookups configured would be useful.


Do you have Row Owners applied to the sheet that contains the name, or only on the sheet that contains the forum? If you also have Row Owners applied to the user sheet with the name, then it won’t work because the user who received the forum does not have access to the data that does not belong to them, such as the name and image of another user in the user sheet.

Thank you for the reply. I do not have any row owners in the user sheet, I also do not have any filters or sorts on. Please see the screen shots below. Firstly the name or profile name does not appear. Also the task only appears for the person who is assigned the task. The person who assigned the task nothing comes up on there end.

Not to be a stickler, but can you also show a screenshot of your user sheet?

Can you also show the filters for the inline list as well as any filters on the screen itself?

Yes of course!

User Sheet

If you need anything else please just let me know.

Nothing is really jumping out to me. Does the same thing happen in the published version?

Otherwise I would try refreshing the browser, or removing and re-adding all lookups and relations.

Hi Jeff, Yes the same thing happens everywhere. I have tried re adding everything and have tried formatting it in different ways.

Would you be willing to make your app copyable, so I can take a look myself?