Problem with dates

Hello, i have a weird problem, look in my table, in first image this is the dates I have (so what dates I want).

And look what I get when I setup the column into “date”.

It’s a bit weird, and I can’t use “computed columns” because I need the date for a filter in a Bigtable.

As you can see the dates ar not the sames

Which version do you need for your big table filter?
What if you create a text to date column, so you can have both versions?

Text To Date dont work with filter on big table

Well, then how about a Format Date column to convert the date version into a text version?

The root of the issue might be the “Start Date” basic text column. How are you collecting those dates? From the outset, is there a way you could collect them in a date format/column instead of as text?

1 Like

Actually, this text are a date format in excel… and i Glide too, what i dont understand is why the date are Not the same when i turn the column into date column instead of text column.

Glide has 3 date formats. Short, Medium, and Long. Those are the choices that Glide offers on a date column. Formatting is always applied on top of the underlying date value. That formatting is for display purposes only. Not only to make it look consistent, but also to make it look better than what the real underlying value is.

You may not realize it, but in most cases, the underlying date value looks like this if it’s set from a date picker:
Not pretty to look at but it’s an international standard that is recognized around the world, so that’s why Glide has the formatting options. The formatting adjusts to display properly based on each user’s region/locale. You could type in a date multiple different ways in each cell, and glide will display it in a consistent format. You can even type ‘Today’, ‘Tomorrow’, or ‘3 months from now’ into a date column and glide will always display it as a properly formatted date using one of the 3 formatting options. If I view dates as MM-DD-YYYY and you view dates as DD-MM-YYYY, then it will display accordingly based on my preference, and in the proper language.

I’m not sure why you are even formatting the dates in Excel. You should be using the raw date value without any formatting, because when you start applying formatting in excel, before it gets to Glide, then you can get weird results. I use Google sheets and I don’t mess with any formatting in the sheet. My sheet is purely for storing data and nothing more. I don’t care what it looks like in the google sheet. I only deal with formatting in Glide.

It would really help if you answered this question and explained in greater detail what you are trying to do. I realize Big Tables have limits with computed columns, but it’s not really clear what you are trying to do with that date column.