Problem selecting a date in calendar

Hello all,
I have a probleme in the app display: when selecting a date it shows sometimes the day before. It happens for April , 1st ( it displays 31/03/1977) and October 25 1987 (it displays 24/10/1987) . Can someone please help me ?
Thanks a lot image

Wow that’s a bit strange. Can you check if you have correctly the columns set to date and when pick a date that is that one the column that you want to edit and also that is the one you want to display it? maybe is happening something at the backend.

Thanks a lot for your answer , yes I checked all is ok , it is the correct column on the back end. Even weirder on the builder it shows the correct date but not on the link for the app

On the builder

wow thats super strange

Where is it gathering this information from and is there something adding values to dates anywhere in glide or in your spreadsheets?

In my sheet the column is set a “date” and in the builder sheet also.
it is displayed as a an action text /
the only way to modify it is on each persone profile via the little crayon and via a date picker

I don’t know if that’s clear enough?

it’s clear. I was thinking if you did a math column or something like that but if you said that its simply normal i don’t know what could be. Have you tried to make same with another column? maybe is bugged or something

Have you tried other phones or other brands of phones? I’m wondering if the device itself is having trouble converting and displaying a date properly. I know when doing date math, you can run the risk of date drift if you don’t properly account for leap years. It all depends on how well a device is capable of converting the underlying date to a friendly date format.

2 Likes

I’ve tried to add another column but I have the same problem again :frowning:

maybe you are right, I’ve only tried on iphones ,I will try with other brand.

1 Like

yes , no problem on Samsung, must be an iphone error !
Thanks a lot
anyway to correct that?

1 Like

IPhones=trouble. Not worth their value :grinning::grinning:

1 Like

Yes, destroy all Apple devices. :wink: They’re holding the rest of us back.

I would be curious if you tried a different browser on the iphone. I wonder if the browser is interpreting the date incorrectly, or if it’s the OS. It’s hard to say if it’s a Glide, OS, or Browser issue. Maybe try a date/time picker instead and try with midnight for the time and maybe a couple of hours after midnight to see if that does anything. Just trying to think of different things to try to narrow down where the problem is.

If you get to the point where you test with different times on the same date and it starts to work, let me know.