๐Ÿ†• Please try the new Glide builder

@Darren_Murphy Thank you for your reply.
Iโ€™m in Taiwan, but I will ask my colleagues in China to try.

  • End User (client) <----> Glide Servers <-----> Glide Table

Hope China did not block Glide Servers.
I was testing before, the following process cannot be used in China.

  • End User (client) <----> Glide Servers <-----> Google Sheets

Thanks

@Darren_Murphy I am currently making a Glide App in the US. I originally intended it for my US colleagues, but am currently trying to use it for my colleagues in China too.

My app is setup to limit access via email. I am not using โ€œAllow sign in via a Google accountโ€.

They are unable to login. It doesnโ€™t appear to be an issue of getting access to the Glide App servers, but rather the email access feature isnโ€™t working. I donโ€™t want to make my app public - it is intended to be used for internal purposes only.

Cannot login glideapp

According to my contact, this translates to, โ€œthis email account canโ€™t use this APPโ€.

Any help or insight on this issue would be appreciated!

I know this is an obvious question, but is the email address they are using actually included in your allowed email list?

@Darren_Murphy

Yes it is. Double checked. They also have dual emails ending in .com or .cn

We tried both and they didnโ€™t work.

Thanks

Okay. Iโ€™m not sure what else I can suggest.
An interesting test might be to create another very simple app, and make it public with email, and then ask them to test that. That would at least rule out the possibility that itโ€™s anything to do with your app thatโ€™s preventing the sign in.

Another thing that might be worth a try would be to register a domain in China (youโ€™ll need somebody in China to do this for you), and then use that as a custom domain for your app. No guarantee that would work, but could be worth a try. If that did work, then youโ€™d probably end up needing two separate versions of your app - one for China, and one for the rest of the world. But you could have both apps using the same tables/sheets at the back end.

@Darren_Murphy Thanks for the advice!

I will try one or both of those and report back.

@Darren_Murphy my contact in China got back to me after I made a few trial apps. He gets the same error with all the different sign-in options. Looks like the functionality is blocked completely due to IP address of the server?

mmm, I think thatโ€™s a reasonable conclusion to make.
Are you intending to try the custom domain option?

I guess another thing that might be worth a try is to work with a CDN provider such as Cloudflare (there are many more). It depends how much trouble you want to go to, and how much time and money youโ€™re willing to invest to find a solution.

A last resort option would probably be VPN, but thatโ€™s almost certainly illegal and would be very risky, especially if youโ€™re operating a business in China.

In Map Style/ default view option icon with bug

Other bug. If I use one of main Styles (not Details style), for example Tiles, and click+ctrl (so in select mode) on Tiles it anyway goes to open details. But I expect to open inline list options.

@Jason

I think if there is a minor improvement here better to have a glide table icon in the dropdown to match the style in the data tab

wow this is beautiful

Hello. can you please tell me where you found the delete option? I am pulling my hair out, and canโ€™t find it anywhere.

The delete option is inside of an Edit form. Also you should have the option to assign a delete row action to any component that accepts actions.

Can you dumb that down for me? I want my users to be able to delete what they have posted, when necessary. Can you Show me where to look, Please?

Click on the pencil icon to edit the post. That will put you inside the edit form. There you can enable the delete option.

ok. I will try that. thank you.