New rows being Edited in instead of Added?


I have been using glide for a personal app for a few weeks now. In my app, I have the option to let users add stuff to the app. Now for these past few weeks, how that option worked was it added a new row to the bottom of the sheet whenever someone put an item in. That served 2 purposes, first, it preserved the custom format of the columns and second, it made it easy for me to script custom functions in the script editor since I just needed to validate the entries using “INSERT_ROW” for OnChange.

Now it seems like the new rows are not being added in, but being Edited in. That makes the new rows have the default formats (on bold, no centering etc) in the sheet and also makes my custom function useless. (I logged the interactions and can verify they are now being Edited in instead of Added)

I was wondering if this is an intended change or did I mess up somewhere. It was working flawlessly till 1 - 2 days ago but suddenly changed overnight.

Can someone help me with this? I’m stumped.


Do you use the “+” button for adding, it should not be a problem because “+” and “pencil” buttons should not be confused.

Yes I’m using the + button for adding. The pencil button correctly registers as an Edit event. But now even my + button is registering as that.

So your “+” button is editing rows instead of adding new ones?


It does put the info into a new row below the others, but instead of it being a “INSERT_ROW” operation on OnChange (as it used to be for me), it’s now an “EDIT”.

Is there any chance you have “blank” data in that row before it is inserted in, I don’t think that’s the case but I can’t think of any other cases.

1 Like

There isn’t, unfortunately.
I deleted multiple rows after my existing last row just to eliminate this case, it still doesn’t “add” the info in.

I even duplicated the spreadsheet (didn’t wanna do it manually, too much data) and remade the app from ground up on it, but it still just edits the new rows in instead of adding them in.

I guess I’ll just rework my custom formula to work with edit instead of insert_row. Seems like a bug somewhere which isn’t so obvious. No worries, thanks for your help btw!

Would a setup like this work? You will have a “last edit” column to store a timestamp for the latest update. Your trigger will now be based on that column instead of the insert/edit type Google pulls back. I think a column like that is much more reliable.

1 Like

That seems like a better workaround than I was thinking. I’ll give it a shot, thanks!

EDIT: It worked! I made it simpler by not using timestamps and just going with a “is_new?” column, which has a “Yes” when added from Glide and gets converted to a “No” after my function runs (since it only needs to run once). Works flawlessly and like you said, should be much more reliable!
Really appreciate you helping me out on this. My implementation would’ve been entirely in script and probably would’ve been buggy as hell to start with, so I really appreciate your insight. Thanks mate!

1 Like