Missing columns in export

When you export a table, it seems like it only exports columns with data in it.

Is this a feature or bug ?

I am trying to migrate from legacy to new and was hoping to export from old and import to the new, but even though I do not have data in the columns, I need the columns.

If you right click on the table in the data view and select export a dialogue will pop up allowing you to select any columns you would like to include in the export. If it’s a computed column that contains a result you will see the result but of course, the computation settings aren’t exported.

Alternatively, if you click the 3 dots at the top right of your classic app (in the dashboard) there is an option that says something like “Create a new app from this data”. This will create a new app that is connected to your current data source.

Hi Darren,

I found the issue/s

  1. The column must have data in it, if it is an empty column it will not copy it even if it is checked at time of export
  2. if you have duplicate column, then it will not copy it the second one it finds (makes sense)

I am actually trying to change the source (get rid of google sheets due to high number of syncs) so I need to recreate it, which I don’t mind because this is a legacy app, and I have been lazy.