Map based on address field displayin incorrectly

I have a field (address) and want to add the map component (not location!).
It is displaying another point in the city. If I “click” on the map it will open another Chrome tab with the correct point in the city.
It soulds as if by default, the app will show a standard location… Not very useful.

Quite sure I am entering something worng somewhere!


Can you try using a service to convert your address to coordinates and use the coordinates to display the map instead?

Thank you very much.

I browsed in the template list for an app using a map and of course it did work.
So I copy/pasted that address to my own app and it kept working.
I finally changed the address but kept the same syntax. Crap! Blank map… I was totally lost.

After your recommendation, I picked the coordinates from OpenStreepMap and pasted into my app and BINGO!

I would still like to know why it wasn’t working… But anyway, it is fixed now :slight_smile:
That was fast.

Did you happen to go through the same issue?

Would you be able to share the address you are using? Just wondering if it’s structured incorrectly. Of you look through the forum, there are several posts about maps and using coordinates instead of the address. Mapbox’s on the fly geocoding is not always the best, but it varies.

Catamarca 45, Acassuso, Buenos Aires, Argentina.

(BTW, now I’m struggling with Google Maps because it is not displaying the correct street view, but too much for Sunday night…)

I gave it my best shot trying different variations of the address. I’m assuming it’s the Habitat for Humanity??? I tried the address that google gave, and the address on the Habitat website, but neither worked. I honestly don’t really know how addresses are structured in Argentina and I’m assuming that maybe Mapbox doesn’t either. Coordinates is probably the best way to go.