Manually deleting multiple rows Glide Table

I’m trying to manually delete rows from the Glide Table however it seems that even if i select multiple rows and click delete, only one row is deleted at a time?

any idea whats the best way to delete multiple rows? i have around 4000 rows i want to delete.


What OS are you using: Windows?

Do you have the same problem on all your APPs?

Yeah, this is a recent regression. Glide team is aware of it and I believe a fix is on the way.

In the meantime, one thing I found is that you can select multiple rows and just keep hitting the delete key and get rid of them one by one. (Yeah I know that’s not a lot of help if you have 4000 rows to remove).


Hola !
I haven’t needed such a mass delete before, to be honest i never realized this problem before… i used to select 2-3 rows and click delete (thought it used to work !)

Thanks Darren, i’ve been doing so since your message, nearly done :joy:

this is a log table actually, i set it up to keep track of all actions on the app and all of a sudden it reached 1000s of rows. I deleted already plenty but i wake up in the morning and its even more :man_facepalming:

I’m thinking of deleting all add row actions to this table first. I guess then it won’t be counted to my row count as i never call anything from this table. I only see it in the editor.

Yeah, if it’s not referenced anywhere then the rows shouldn’t count.

If you’d like to turn it into a sort of FIFO log, there is a trick that can be used to automatically delete the oldest rows. All you need to do is use a Single Value or a Rollup to identify the oldest row in the table, then build a Single Relation to that row. Then you can include a Delete Row step in your Add Row sequence that deletes that oldest row. The end result will be that you’ll have a rotating log with a fixed number of rows.

1 Like

Yes I have that in other places in the app but the issue is I need to clear these 4000 rows and maybe i could set that up once the table is down to 100-200 rows.

By the way i just finished manually deleting all rows (kept my finger on the delete button)… closed app and opened again to find the count still at 2900 … so i guess even that doesn’t work unless you give time for Glide to delete before you click again.

Yes, apparently mass deleting rows via the data editor doesn’t play well with the Glide back end.


Seems like mass deleting multiple rows is functioning again in the glide editor.
However, i would advise anyone using it to avoid any further actions in Glide after deleting and to reload app to confirm. It doesn’t work well for a big number of rows. I tried a couple thousand rows at once and although they disappeared from the editor. On reload, most of them appeared back again. But still its working, unlike before where it was deleting 1 row (the first selected) only.


@rayo you could have a look on this post. It also describes deletingv

1 Like

hello @Darren_Murphy , how about mass editing ?
is it possible ?
if i want to create a new basic column, but want to fill all of the existing record the same value at once

I think copy/paste would be the easiest way to do that.

But… if you want the same value in every row, why not use a template column instead?

1 Like

Try this one:


tried, when i block all the cells and paste, it only paste the first row cells, not all of them

i dunno why

impressive and how did you manage that ?

but i notice that the first row didnt get to edited ??

and when i enter the item screen, it didnt change?

1 Like

did you have any filter on?

nope, the first row goes blank

and after i bulk edit the second column, it shows but the original text, not the edited one

im gonna check it out… i did not look at this app for a long time… and glide made many changes since then

1 Like

It is fixed… thank you for pointing it out :heart_eyes:


but im still wondering why the changes doesnt effect when i go inside the item screen ?