How to delete or clear rows in Glide Tables? - newbie

Hello All,
I am a super new user to Glide. Still getting my feet wet. I am mocking up an app for our company to see if the sales staff would like to use this SaaS.
I copied the Property Management app and editing for our use. After a search in documentation, videos, and here at the community, I can not find how to delete or clear rows of data. :weary:
In the screenshot below, I would like to clear/delete the data from row 4 down.
How do you do this simple task?

Thanks!
Ana

Welcome Ana!

Hover the mouse at this little square next Row ID column, you’ll realize that you can select a row

Select the row you want to delete > press Delete in your keyboard

1 Like

I did everything but that… Use the keyboard delete. :woman_facepalming:

1 Like

I don’t know if this consoles you, but it took me a long time to figure it out :sweat_smile:

2 Likes

@ana_lee if you have lots and lots of rows then you could use a robot to delete the rows as described in this post.

3 Likes

@Krivo Thank you! I bet this will be helpful in the near future.

omg- i was trying to do the same thing yesterday and could not figure it out ! thank you !!

1 Like

You’re welcome!!

Thank you @Lucas_Pires, I have an additional query. Once deleted, is there a way to recover the row(s) in Glide table? I tried Cmd + Z but it didn’t do anything.

1 Like

Hi @go_dash by now, Ctrl+Z doesn’t work in data editor, unfortunately

1 Like

Glide does warn you about that…

Hey there, i did all that and it still wont delete a row inside glide tables… Help?

Can you record a video of the problem in action?

I just found an issue in the table where if there is no basic data consisting only of row ID and compute column, then the row cannot be deleted.

Works for me.

2 Likes

Or the usc column is the cause?
I have tried it many times. This is really weird.

Also works fine with User Specific columns included.

Is it the same if you duplicate the setup in a sample app?
If it is, you could do that and then remove the columns one by one until you identify the culprit.

1 Like

After I duplicate it can now be removed. Weird. :upside_down_face: