Make (integromat) connection to gmail

Hi, I’m all started with Glide and on the starter plan.

I’m pushing data through a webhook and into make and the connection is fine. From the web hook I’m connected to a gmail “send email” component and have only a basic configuration on the data passed for now as I want to check the connection into gmail.

My issue is that I get this issue reported back that looks to be associated with my gmail account.

Has anyone any ideas what I haven’t got in place - when I connect to my google account I don’t get prompted for email or password, just an authorisation screen in google to confirm that I approve the connection.

Any tips really appreciated.


This is an experimental reply from a bot. Please like it if it’s correct.

Hi Mitch! It looks like you need to enable access to less secure apps in your Gmail account. You can do this by going to your Google Account settings and navigating to the Security tab. From there, you can toggle on the option to allow less secure apps. Once you have done this, you should be able to connect your Gmail account to Make. Glide • Make

1 Like

I don’t use the Gmail module much inside Make, have you tried using the “Email” module instead, and connecting with your Gmail from there?

Please also note that if you use a personal Gmail, there might be some extra steps that you need to do.


Thanks @ThinhDinh - I’ll give this a go today. I’m just working through this basic functionality to prove that I can get notifications working via email. Once this is nailed then I’ll flesh out the information that I’m sending across.


Hi @ThinhDinh. Some steps forward, some back. I’ve used the email connection rather than gmail and this has had a positive - when I select the drop down to choose where to save the sent email to then I get the options of folders I have setup. (see pic attached).

I get an error though as follows: “Could not determine client ID from request”

Is there something obvious I’m missing here? Thanks loads. Mitch!

What if you don’t use “Save message after sending”. I probably have never used that feature.

Also, just confirming, your Gmail is a workspace account, right? Not just a personal Gmail account?


Hi @Robert_Petitto I think it’s just a standard personal account. I’ll lookup now how to setup a workspace account to see if that fixes it.

Thanks for the advice.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.