Login on iPadOS / Safari

Hi Gang,

It’s been about 4 days that I haven’t been able to successfully handshake my google account with Glide and get logged in on my iPad. I generally am fine as I have a PC I do my heavy lifting on… but it was working beautifully previously.

It’s just hanging there… anyone else experiencing it? haaalp pls. :+1:

Thx,
Paul

Any suggestions? Who is CX who can point me in the right direction?

Yeah, I’ve cleared cookies and the like once already… hoping someone at Glide HQ can check one of your demo ipads and see if I’m having an ID 10T error or not. :wink:

I don’t think iPad is officially supported for the builder. Maybe a recent update changed something to make it not load completely on an iPad.

This is a basic authentication issue, the interface works really well in iPadOS. I discovered Glide on my iPad and made my first app on it…

Ok I’m tagging ppl in here now… @Jason @JackVaughan @david… (Sorry)… Help!? :wink:

Hi there seems to have been a bad version of sign in that went out from Google. We are aware of the issue, fixing it however requires manually invalidating your cache with Google. I will get @Daniel_Sweet to come give instructions since I fixed it by nuking my entire browser profile… Which sucked. He found a better way.

Hey @Paul, sorry to hear that you’re having login issues here. We definitely have seen this on our end, and it looks like Google made some mistakes in their own provided software. We were getting stuck on these bad versions too until we removed some problematic website data.

If you clear all website data related to “googleapis.com” then the issue should disappear. I don’t have an iPad handy at the moment, so the process may be different for you, but I think this should still work:

Open Settings, go to Safari, go to the Advanced settings, and under Website Data, search for “googleapis.com”. You’ll see quite a few sites there. We’re not sure which specific site is the problematic one so just delete them all. On iPhones you have to dismiss the keyboard and press the “Edit” button in the lower right hand corner to be able to delete items here.

I’ll have access to an iPad tomorrow to confirm that these general instructions are valid.

Thx gang. I gave it a go deleting my entire cache and also stepping through removing the googleapis.com data settings. No luck unfortunately. I’ll keep on truckin’ and await your advice tomorrow. :+1:

Hi again Paul,

You might have to try removing everything from “googleapis.com” as well as “go.glideapps.com” at the same time. If that still doesn’t work please let us know.

This is what was cached that I cleared

Unfortunately no change in result, still just hanging at Signing in… I guess my device setup (iPad Pro 12.9” with 13.3 (17C5038a) installed has a ghost in the system. We can blame Google auth.

The fortunate news for my customers is it’s meant I’ve gone back to doing other work for them rather than playing with my projects (in Glide)… haha.

If you have any other ideas let me know! Appreciate the efforts. :+1:

Hi again Paul. That’s unfortunate that clearing only some website data isn’t working out. You may need to try to clear all website data entirely.

If that still doesn’t work, we might need to schedule a call.

I have tried blowing the whole lot away a few times. Tried again, no luck. There are a lot of settings under the hood of Safari that might be impacting somehow… although I haven’t really tweaked anything away from stock.

Happy to schedule a call in due course… no rush. I’m in Melbourne, Australia so finding a time could be fun. :wink: