Issue with custom actions & template columns

Any advice on how to get around this issue.

i’m having a problem with using template columns in Glide in custom actions.

to simplify things.
imagine this table

text column 1 text column 2 template column 3 (1+2) text column 4
Hello Name Hello Name -

if we create a custom action that looks like this

action 1: set column1 to Good Bye
action 2: set column 4 to column 3 value

we expect the result to be

text column 1 text column 2 template column 3 (1+2) text column 4
Good Bye Name Good Bye Name Good Bye Name

but this doesn’t always happen !
because between the actions, sometimes the template takes a longer time to execute

action 1: set column1 to Good Bye
here the column 3 template column does not execute in time
action 2: set column 4 to column 3 value

hence we end up with

text column 1 text column 2 template column 3 (1+2) text column 4
Good Bye Name Good Bye Name -

Previous discussion on this topic.

I don’t have a lot to add from my earlier comments, however one thought I had is whether you can explore opportunities to preset the value of the template column? Perhaps as part of an earlier action?

Are you using a native or custom form? If the latter, it would probably be easier to preset.

Other than that, it might be worth your while submitting a ticket to Glide support.

Thanks Darren for help as always.

Yes i considered the option to preset the value of some columns
though not the template (as that cannot hold a custom value)

things still didn’t work out. I’l try to record something though hard due to the user data showing on the screen.

the above example maybe wasn’t clear. a quick example could be this:

column 1 text column 2 text column 3 template 1+2
date is 15/2/1998

if i have a custom action that does

  1. set column 1 to “Today Date is”
  2. set column 2 to “Current Date/Time”
  3. Show Notification Column 3

although the result should be a notification Today Date is 15/2/2022.

the result comes out as "Today Date is - " with an empty value from column 2.

current date/time takes more time to execute than the action and hence is not returned on time.

1 Like

hi @jabid
maybe a simpler example of what I meant.

Just taking that example in isolation, would that work better if instead of using column 2 in the template, just use the current date/time?

So instead of 1+2, use 1 + current date/time

Yes I tried that as well. it works in many cases.
Yet there are cases (especially when a user just starts using the app)
where the show notification of column 3 still doesn’t produce the full value of column 3.

i’m going to put it aside and come back later on record a video maybe that helps explain my problem more and possibly any users have different solutions to get the same outcome I am trying to achieve.

thanks Darren as always!!

Are any of these Set Column actions operating through a Single Relation?
I ask because I’ve seen instances in the past where a Set Columns via a Single Relation will fail the first time an app is opened, and then work afterwards. I’ve never been able to figure out why it happens (or find a solution), but I have seen it happen. The best theory I have is that the action takes place before everything on the local device has finished computing. But even that doesn’t make a lot of sense, as sometimes I’ve seen this happen some few minutes after the app has loaded.