Inner list - Callendar - Wrong date format

Hello,

The date format form Inner list, calendar, date is showing in american format.
For 01/03/2020 (europe format) it is showing Fri, 3 Janv 2020 insteaf of Sun, 1 March 2020

My google sheet is in europe format.

Regards,

1 Like

What region is your browser set too? It should show correctly on each device depending on each devices region settings.

My browser is set to europe, this is why I do not understand where the issue comes from.
I think it was working the past few days, so I do not know what happend. For the moment, I have created an other column with the date in US Format so it is well displayed.

Does it display any different in the Glide builder compared to on your phone or when viewing the app in a browser? Do you have any screenshots of the date in the data tab? Are you typing in the date manually or is it coming from and date entry component in the app?

Hi,
It now displayed the same between phone and viewing the app in a browser. However I had to create a formula to switch from euro date to a US date format.

  1. User type EU date
  2. Another column format the EU date to US date
  3. I choose to display the US date format in “calendar” inner list
  4. the day and month are correctly displayed in the app

So even if my device are in euro format I had to create a column with us format to have the dates correctly displayed

Also is there a way to stop showing the date when choosing calender in inner list ? (see Screenshot)glideapp

There is no way to stop the time from showing. The only option is to use a list instead of the calendar and display the date (formatted however you want) in either the Title, Details, or Caption of the list.

It’s a recurrent issue. Even if you force the format to be European in your sheet for the date columns, it works for some times and after several new roslws added by Glide, the format is back to the US format, both in the sheet and the Glide UI… It’s a real problem yep…

1 Like

yep please

yes but then when setting order it does not show accordingly

It orders according to us format MMDDYYYY even if it is FORMATTED DDMMYYYY

You can always create a column formatted in YYYYMMDD to use for sorting.

A date formatted as text may or may not be recognized as a true date column. A true date column (recognized by the calendar icon in the data tab) should story properly in date order, no matter the format I think. If the column is recognized as a regular text column, then YYYYMMDD works for sorting and you can use DDMMYYYY in another solution for display purposes.

1 Like