Incorrect Details Screen from inline list

My App/Pages support link:

Describe the bug:
When I open an item from inline list, I can’t use fields from corresponding table (Flights).

Expected behavior:
When I open the item from inline list (calendar type), I see fields from item and corresponding table.

How to replicate:

  1. Open “Полёты” (last tab)
  2. Pick any item.
  3. Press 3 dots on Title at any item.
  4. See fields from another table.

Link to demo recording:

What’s the action on your inline list?

1 Like

One of my clients experienced the exact same thing. I tried every trick imaginable, but wasn’t able to figure it out. Definitely a bug. I had them submit a ticket yesterday completely bizarre.

Source was Google sheets.

It didn’t matter whether the screen was sourced from the sheet or I had an in line list, pointing to the sheet, clicking on a list item, directed me to the detail screen of a completely different sheet.


Was the component previously copy/pasted and then modified? Recently I’ve seen components hanging onto original settings/sources after being copied and pasted elsewhere. The component had to be completely removed and re-added in the new screen to grab the right data.


We tried creating a completely new tab and new components…no dice.

What’s weird is that if you switch the action to “show new screen” it still doesn’t work—it defaults to a completely different sheet in the drop down.

1 Like

“Show detail view”, as described.

1 Like

Exactly! I use internal tables in this project with the same bug.

No, as a workaround, I’ve tried to recreate it again and again. As a Detail screen with inline component and as a calendar type screen with same behavior. I’ve recreated a whole table to test if it can help. No success at all.