Images not updating stored in S3

I have stored some images in public in S3 bucket. When I change them, they are not updated in my glide App. I tried reloading cache as well. Any help is appreciated. Thanks.

When you say updated are you adding to them or changing them? Are you adding these to your google sheet? Do you currently have PRO?

I ask these because if you do not have pro and you are not making changes to the app or the sheet and they are added elsewhere they will not update. Without PRO it only updates “On edit”. If you do have PRO make sure you have that changed to the other option which is “While editing or using the app”

I am not PRO yet. But I tried what you said. But my icons don’t show the new files.
When I open the URL from S3 in browser, I do see the new icons.

I changed the App. I changed the sheet and reloaded it. I changed the image URL to something dummy and back.

FYI, I am assigning image URL based on If then else condition to a column in the data editor.

Friends, any update on this will be very helpful.

If you have any image urls you can share and a screenshot of your if/then column settings and the image component setting, that might help.

1 Like

Glide caches all images. You must change the URL if you want Glide to update the image.

You can make the url unique by adding a query parameter that you can manually change to get an updated url. I think @david will also recommend not using a date value like now() to make the url unique. Just use something that you can manually change or that can watch for an additional column in your sheet for when it changes.

1 Like

still an issue here @david despite the URL update

I am creating dashboards as images, store them on google drive, use a script to update the URL with a counter or date on each change to the dashboard/image (with “…&update=somechange”).

In the App, the image still does not update. Only when I use the “enlarge image” feature on the image component, the new image is loaded. In the app though, the image in the image component still does not update. Worse, it sometimes even loads an older image.

any help here?

@Jeff_Hager any update here? I really tried every single way to use an updated URL… nonetheless, the images in the App do not update accordingly (also, with the enlarge image one, it sometimes loads an old image)

I don’t know. I’m guessing there is caching going on somewhere. Can you show any screenshots of how you are updating the url?

This is how they get updated: (adding a “&updated=xxx” at the end with xxx being a counter

Image in the App (not updating):
Image in the App (when clicking “enlarge” -> which shows the updated image)

No idea. I’ve never had to deal with a scenario where the image changed, but the url stayed the same. I only know what’s been suggested before, and that’s to modify the url like you currently are. I know Glide caches images, but I don’t know how that process works. I suppose there could be aggressive caching on your end too, but I don’t know. It’s probably more of a question for Glide. You can try clearing your browser cache to see if that makes a difference as well as make sure you have clicked on reload in the editor to make sure glide has the latest sheet data.

Thank you anyways Jeff. Much appreciated!

1 Like