+ Icon Data not applying

Hi Everyone, I am not understanding something with the plus icon at the top of the screen and it is making me crazy.
My app uses row owners connected to user email
And data comes from User Specific Columns

I go to a tab
Each tab has a page of cards
Each card goes to detail view of that card

When on the cards page if I click the plus icon at the top of the page to add a new additional card it takes me to the screen that shows the text input fields.
I input the text to fields
click the check mark
it takes me back to the tab of cards
I see a new card but it is blank
Click new blank card ( that should have had data i just entered )
land on a blank details pg that shows lines where data should be

This is happening every time on my phone in app, and I am getting mixed results (sometimes data shows, mostly not) in the data editor on my laptop. I have wasted countless hours trying to figure this out.

Someone PLEASE send step by step instructions for adding a card with its data using the + icon at the top of the app before I go crazy! lol

Can you add a screencast of the issue?


That is what I get after I input data for new item, Blank on card, then blank with lines on detail
Any suggestions? Please and Thank you! Lol

You probably meant this screenshot. Sorry I wasn’t thinking!

What’s the set Column Values doing?



On Submit - Set Column Values
Row - This Item
Everything else is blank and has the word custom auto populated. I had just assumed that is where it applies the values for user specific columns ( obviously I was mistaken lol )

Might be worth mentioning when I am NOT using User Specific columns it adds a new card just fine. Im so confused!

I’m sure I am just missing a step somewhere but cant figure it out and have now held up my project for a week. It would be so helpful if I had an outline or some step by step instructions for adding a new card when using user specific columns.

I have read through the forum and the tutorials. There is a lot of different info / ideas / hacks and I am getting confused and frustrated. It seems like “adding new” would be a very basic thing that would be easily accomplished by anyone using glide with some standard documented procedure.

Is it just me? Why is it hurting my brain??? Please Help!

Get rid of the set column action and try again.

no change :slightly_frowning_face:

It looks like one of two things is happening:

Either one, the moment the record is created something else is clearing the values immediately afterwards (my reasoning for getting rid of the sick column action), or two, you have row owners enabled on the table with the submission data and the “email” column is empty.

Im pretty sure it is this - you have row owners enabled on the table with the submission data and the “email” column is empty

Are you saying that every glide table that uses row owners needs to have a user email column also?? And this is in addition to having user email column in the the user profile table?

Can you tell us what are you trying to set to the row you have just created? Wouldn’t it be better to use an entry component and have a default value instead?

You have to pass the email of the user who created the record to the destination table so you can apply row owner to that table, for that column.

I would be suspicious if you are trying to set user specific columns on a row that has just been added. In that split second, a row id probably hasn’t been generated yet, so the setting of user specific columns will not work correctly until the row ID is established for the new row.

Im So Confused!!! :sob: :sob: :sob: :sob:

How do I go about paying an expert to fix this or change from form to user specific component and to double check my settings?

Im too frustrated at this point, and just need this done quickly and correctly. I have almost everything done. Just these last couple things

You can find and contact any of the experts listed here

If you haven’t found anyone yet, send me a private message.
If it’s a simple fix - as I suspect it probably is - I won’t charge you anything.