Hide times in Calendar view

Ability to hide times in Calendar view would be nice.

Or at least show correct times.

There’s definitely some sort of bug for time of day. When I first enter something, the time is displayed correctly (matches what I pick in the Date/Time picker), but after a minute or so, it changes to something else (for me it’s changing it to 5 hours prior). Seems like maybe a timezone issue…?

The data in my sheet is correct, but the way it’s displayed in my app is using the wrong timezone. @JackVaughan @david is this a known bug?

Mine all start out OK, then they end up as 12:00.

Are you using the Date/Time Picker, or just the Date picker? That was my initial issue, now it seems to be timezone-related.

I was using just the date picker, made the change to the da/time picker, nothing has changed.

You’ll have to either edit the previous entries, or delete them and re-add them to give them time values (I think).

That doesn’t work. I edited one, went back to the calendar view and watched it switch from 1:27 PM to 12:00

Hmm not sure then. For me, not only do my times get adjusted to a different timezone in the app, this is how they display:image

Yeah i don’t know, it keeps changing back for me.

That’s how mine behaves for the timezone change. Not sure if it’s related.

The display of dates/times isn’t set up the best either. There doesn’t seem to be a Date/Time display, just a picker. When I use Basic Text, I get the formatting I showed above. Not sure if this something that is being worked on, but it’s seems like a work in progress.

Here’s a shot of a different version of the app - the calendar view is the same, but the text version shows the correct time. FYI - the time is correct in the spreadsheet too.

1 Like

This could be because the datetime needs to be formatted as mm/dd/yyyy hh:mmAM/PM for it to be properly displayed.

From what I have seen this is not consistent across sheets. My datetime is formatted as dd-mm-yyy hh:mm and it displays just fine. But one of my friend’s apps displayed this weird behavior of the time switching to 12:00 as you look at it, and the reformatting to mm/dd/yyyy fixed it.

You could also see if the sheet’s and browser’s locale is set correctly.

2 Likes

Lots of good information @Doomba. I’ll check it all out next week to see if they help the issues I’m having.

Hey @shchc, thanks for this. Yes, as people have said - please keep the format as described in the docs. I just replicated your issue, but then resolved it when I made sure the format was MM/DD/YYYY HH:MMAM/PM

Hope it’s solved for you as well.

1 Like

My date/time issues were solved once correct format was used in the Sheet. Appreciate the help!

1 Like

You can always create a column in your sheet that reformats the date into a view you prefer using the following formula:

=TEXT(datecolumn, "DD/MM/YYYY") Never rely on setting column formatting from the spreadsheet settings themselves.

This fixed my issue, thanks!

1 Like

In the datetime picker during edit it would still go back to the original column’s setting though, wouldn’t it? Since it’s writing to that column.

@Doomba You you don’t write to the new column when editing, you only write to the original date column. The formula reformats the date how you want, Then the new column is used for display only.