Glide Table Data Gone

Whole Project Table Wiped out…I signed up for new previews and started to make row owners tonight and I have no data in the glide table…WTF to do?

I am really trippin that a whole table of data was wiped while I was routinely setting row owners…OMG…Is this trustable?


Don’t trust AI. It hallucinates.

Just refresh your browser window.

1 Like

whole table gone man…I tried but no go

the table is there but every row is gone. I duplicated the table and all the data showed but the row ids of course are different…now i get to trace back all these row ids…unbeliveble

Usually when you start messing with Row Owners, especially removing them, the data editor can glitch and make the table appear empty, even though it isn’t. A browser refresh usually gets you back on track. I’ve never heard of data permanently disappearing.

Maybe clearing the browser cache is necessary if a refresh doesn’t work. Clearly the data is still there if duplicating the table reveals it.

as crazy as it may sound when i duplicated the records did in the duplicate…but trust me i already ran the cache/incognito drill…

all my rows ARE GONE MAN

can you try exporting the table?
make sure its the original one not an empty duplicate or table with the same name

been there done that. Thank God it was only 29 unique rows…Man I would retire if it were a batch of 2000 or 200000000

I need to figure out a backup solution asap when using glide tables…PLEASE I NEED THE BEST ADVICE ON THIS

I think the best advice that I can give is to submit a support ticket with Glide. They are in the best position to be able to figure out what happened. Nobody here will be able to help, other than offering general non-specific advice.

Like Jeff, I’ve never seen or heard of this happening before, so it does sound highly unusual.

Assuming that you have a plan that gets you support, you can raise a ticket by opening the App in the builder, then go to Settings->Support and follow your nose from there.

The only activity i was doing in that table prior was assigning new columns as row owners. So Happy it wasnt a lot of data… I just got them all fixed…wasnt bad. I was able to clean some data up in the process…but yea I think glide should know about this and I might switch to google sheets for this besides computed columns… I dont think this would be good if it happened again or for a client of mine…There has to be a robust native backup feature besides google sheets or big query that is stable for backups…

@John_Romano same thing happened to me. I activated Notes and Multi file upload and then when I went back to my project my one table is completely blank. I restarted chrome, logged in and out, deactivate those elements again but nothing.

Logged a ticket with support and got a response that they are investigating. Luckily this is still a development project but imagine it was live and your data gets wiped and you have no way of restoring it nor any immediate priority from Glide to resolve it.

This is very concerning!

highly! Thank you for your input…I feel that if you are going to offer the storage of data, you must by natural default implement a design for regular backups

I haven’t tried but maybe this could work for backups from Glide tables → Google sheets

1 Like

We shouldn’t have to hack together a data backup solution. Now I have to sit and wait until Glide comes back online and hope they give me feedback.

@John_Romano turns out I made a change to one of my forms and for some reason when I did that it added an existing action I had to the submit button which deleted rows to a relation which then caused all the data to be wiped. Have a look at your actions for the table as something similar might have caused your data wipe.


Thx man I’ll take a look!

1 Like