Glide not working on cellular data or mobile data

Hi everyone

I’m experiencing issues with glide working via cellular data. The app is simply not loading or starting at all. Over wifi it work perfectly 100% of the time however the minute switch to cellular/mobile data its almost like the app is non existent.

Any advice on how to fix this as this is a major step back for us. I really like what the team at glide are doing but this issue simply means I can not invest any more money or time with glideapps if they don’t fix this major road block any time soon. Its a shame as everything else is almost perfect.

Would love to hear from anyone else experiencing this issue also.



Do you have a url to the app that we can test?

Hey SantiagoPerez

here is the like -

please note its not just this app my other apps also dont load half the time via cellular data.


What cellular provider? What country/state?

It does load on cellular data at least where I am.

As David said? What country? What cellular company?

Have you tried with different devices on different cellular companies?

I’m using Three mobile in the UK in Oxford, Oxfordshire. I noticed the issue today when decided to try out the app via mobile data and the performance was not good. I’m now looking for alternative solutions as i need to get this project underway.

have you tried saving it to the home screen and open it again? that where it doesn’t load sometimes.

1 Like

I just did and it loaded no problem.

Please take screenshots when trying to visit and

These would let us know what is going on with the network.

I recommend opening a ticket, sending the support link and the screenshot of those two links to

1 Like

Just tried in the UK on O2 network.

Loaded fine.

Probably best to follow the latest advise given by @SantiagoPerez in his post. Maybe a local network issue with 3.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.