Glide Form Stopped Communicating with Google Sheet

My app’s URL:

Been using Glide for several months without hiccups, but I ran into a problem today. I have a form that allows users to make specific requests. Over 1,700+ successful submissions have been sent from the form and show up in the appropriate Google Sheet. For some unknown reason, my Glide form is no longer communicating with the correct Google Sheet. The form submissions will show up in the “Data” tab correctly in the app builder, but they will not populate in the Google Sheet. The app is still pulling in data correctly, just not sending back out.

I share the Google Sheet with others so that we can take care of user requests. I can’t share my Glide login credentials. I need the communication between form and sheet.

Has anything changed on the Glide back end?


Can you scroll down to the end of your Google Sheet and check there?

I’ve been using unique inputs and doing control+F and can’t find them.

I rebuilt the form and connected it to a new Sheet tab…still nothing.

I added a new field to the form and looks like it’s communicating again? Not sure how that works.

I see two rows that were added in the past few minutes (rows 1389, 1390).

Is there a script running in the background that clears out all the rows now and then and writes them back later? If that happens while somebody submits, you might lose data.

Those are the two that I just tried with the newly added “Date” field. It’s now communicating with that new field. Not sure what sparked it.

When I looked at the data on our backend to look at the rows that were added earlier today, that whole “Song Requests” sheet seemed to be empty.

For example, about an hour ago a submission ended up in row 518.

I was playing around trying to figure out why it wasn’t communicating. The data has been put back into that tab. Notice that only two entries are timestamped. That’s when I tried to a date field to see what would happen – it ended up re-communicating. No idea why.