Glide Column Data not showing in browser mode

I have some glide columns that aren’t showing up on the front end. They look good on the back and in the preview but when I test from my phone or computer they don’t show up. One is a math column and one is a roll up column.

Easiest place to see this is on your profile page. Under the standard info it shows your user name and rowID. There are supposed to be 2 more data points between those. I’ve attached a screen shot from the preview mode to see how it should look. What am I missing?

Elsewhere in the app I need to use that data to enter a new item. The data isn’t pulled correctly into my form their either.


Is there data in the rows associated with the “missing” columns?
Many components won’t appear if there is no data to display.
Which components are you using?

Yes there is data. You can see the data in the screen shot of the preview (the 418 and 419). But when I use the app that data doesn’t appear. I only see the G A and then the row ID.

Would this be some sort of bug?

I’m trying to have an entry screen enter a disc and assign it the next ID #. The app uses google sheets with glide columns added on.

My User table has a roll up glide column that gets the MaxID from my list of discs and then a glide math column for Next ID which is MaxID+1.

That way when I have a new item entry screen I can use the Next ID field from the user table to assign the new ID number. It works great in preview mode but not in the app. The MaxID and Next ID values don’t show up and when I try to use the data to create a new id it doesn’t populate.

BUT, the data is there. They’re roll up fields and I see the data and it works correctly in preview, just not live.

Help please?

Do you have any row owners for that Sheet? Can you share a video of the bug with us?

I’m pretty sure this is a bug since the app doesn’t show fields that are shown in the preview. I could do a video but all the info is here. You can see the screen shot of the preview above where the 2 fields show up. the 419 and 418. You can go to the app, log in, and look at your profiel and the 418 and 419 do NOT show up. That’s it. The data is there and the preview works but the front end doesn’t.

Rather than bashing my head against the wall trying to fix the bug I did a work around. Instead of having the ID# set when the row is added, I have an action ‘after submiss’ that sets the id column after the fact. So it gets entered as a blank id and then the action sets it to the ‘next id’. Seems to work after a few tests and is perhaps a more simple/elegant solution anyways.

You didn’t answer the question about row owners. The information you provided suggests that row owners might be related - hence why @ThinhDinh would have asked that question.

Other pertinent questions that might lead towards a solution:

  • When you test with a device, are you testing as the same user in the screen shot you provided?
  • Is the “GA” user the first row in your User Profiles sheet?
  • Have you tested by previewing as other users? What was the result?
1 Like

I am adding rows to a table called Discs. It does not have row owners. I was trying to display and use a field from Users which has the email address set as the row owner.

Yes. I was testing with the same user as I was previewing with.

GA is not the first row, nor the last. It is a testing user/row that I created to try and debug the issue.

I have tried with other users and had the same result.

My apologies if my early reply came off as inappropriate. That was certainly not my intention. I know that Glide has many was to skin a cat and I just chose a different solution rather than trying to make my first idea work.

Okay. Just for giggles, does it make any difference if you remove row owners from the users table?
At the very least, that would help rule out any possibility that row owners are involved.
The reason we often focus on row owners is that (whilst they are the best option for securing private data) they often come with unexpected/unintended side effects.

Other than that, I don’t really have any ideas. It could be a bug, as you suggest.

Not at all, and nothing to apologise for :slight_smile:

Just as a side note, I’ve used the same technique that you’re using (roll up max and add 1 to get the next ID), although in my case I did the calculations in the table that contained the data being operated on rather than my users table. One thing that I’m aware of is this technique is potentially subject to a race condition that could lead to rows with duplicated ID’s. I’ve not seen it happen, but I think it’s possible - if you have multiple users adding rows simultaneously. Read more about that below…

I have already removed the fields from the Users table as I’m now using a different method for this. Although I’d love to understand exactly what the issue was, I don’t have the time to go back and recreate the situation. I hope you understand.

I suppose there are different types of bugs but in short, it all worked in preview mode but not on my device. If it just wasn’t working then that’s one thing but it worked perfect in preview.

For the roll up +1 method to get the next item number . . . How do you use that value as the default? I can’t choose that as a default value which is why I switched to the ‘post addition’ column edit which seems to work well.

As for the race issue, I’m not concerned. I have only 1 person doing the data entry at this time.

Thanks so much for your help and replies.

I described the technique earlier in that thread that I linked to. It requires at least one row containing a value in the ID column to start with, then after that I use the calculated Next ID to populate the ID column when adding new rows. The entry form uses the same table as a base, so the column is available.