Glide and Sheet not in sync - Error 1003 and 1035

I need to figure out how to re-connect my google sheet with my App. I am in the process of migrating from Classic to App and everything was going well (all data is accessible in App) until I tried to create a copy of the new App for a backup. Note that I changed my Google and Glide passwords last week but everything seemed to work until now. I saw this in the community but no resolution (Google Sheet no longer syncing, manual sync unsuccessful)

When I did the Duplicate (copy the sheet) I got this message:


After cleaning up the tables (I did have some blanks in the sheets) I tried again and got Error: 1003 again so I tried doing a manual sync from within Glide and got this message:



I also upgraded to Business if that has anything to do with the Glide/Google login miscommunications…

Interesting - the sheet is disconnected from Glide but Glide points to the sheet. I can add data in Glide Editor but it never syncs back to the sheet. And vice-versa.

Somehow authentication is not working after I changed passwords in Glide and Google (which I did last Thursday) (…and which @Jeff_Hager may have warned me about).

So what is different from last week until now? You had said everything was working fine last week. Did you happen to check if data was syncing at that time, or did you just assume it was connected? If I’m understanding correctly, it does seem odd that you were still able to create a duplicate Google sheet.

I’m pretty sure you ultimately blocked Glide from accessing the Google Sheets properly when you deleted the connection between the two. I think you should have stopped at @Darren_Murphy’s suggestion to remove the particular device, but kept the connection between Glide and Google active. I think that is what is biting you now.

I’m not sure how to reconnect the two at this point. I’m not willing to experiment and find out. I don’t know if there is something in the google settings that needs to undone or redone, or if you need to trick Glide into re-authenticating with google. Maybe create a brand new app and try to connect to a google sheet to see what happens. Will it even show the sheets in your google drive?

I don’t believe changing passwords is the issue here. Federated authentication like this usually uses tokenization, not user/password authentication to maintain a connection between different services. So usually a password change does not affect existing connections unless you deliberately tell it to disconnect.

Thought I got by all this cause AFTER I changed the passwords, etc and relogged into Glide by logging in with email and using login with google account - everything was working.

In fact, I looked at the tables and some were updated as of 11/12.

Last night I wanted to duplicate the app and go

Yea - me too!

Net/net: it worked for a while since I was able to duplicate the entire environment and start working on the App and updated tables (with your cool create an image from text function!) but it stopped working yesterday afternoon and I can not update tables or duplicate the App.

Really hoping that Glide can reset my authentication.

Thanks for following up.

Have you tried creating a new app, connecting it to a new sheet? I feel like something needs to trigger that re-authentication process.

Does Glide show up as having third party access in your google settings, or is it still missing after you deleted the connection?

Does Glide show up as having third party access in your google settings, or is it still missing after you deleted the connection?

I don’t think Glide has access to Google looking at my dashboard (they are not listed as a 'linked account"). This is what I need to establish and I do not see a means to do this on Google or with Glide.

And no - I tried creating a new app…will do that now.

Interesting…created a New App with Sheet asks me which google account I want to use.

I select my Google account and…nothing

No App created…no error or message


Just to be clear - Glide is only accessing google for sign-in. It is NOT a linked account (not 1 of the 2). After this discussion I beleive you are correct and it needs to be a linked account. @Support - is their a process for re-establishing this link?

I am wrong - looks like Glides does have access to my Google Drive unless permission is messed up with the sheet/files. Back to the drawing board…

I signed out of Glide. Got rid of Chrome cache.

Logged into Glide using email. -Same Problem

Signed into Glide using google. - Synch working AGAIN!

Duplicate (copy sheet) - WORKS

Thanks Jeff for providing enough breadcrumbs to guide me through this. Next time, listen to @Darren_Murphy

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.